【HDU 杭电 1051 Wooden Sticks 】

47 篇文章 3 订阅
7 篇文章 0 订阅

Wooden Sticks

Problem Description
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:

(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l’ and weight w’ if l<=l’ and w<=w’. Otherwise, it will need 1 minute for setup.

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).

Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, …, ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.

Output
The output should contain the minimum setup time in minutes, one per line.

Sample Input
3
5
4 9 5 2 2 1 3 5 1 4
3
2 2 1 1 2 2
3
1 3 2 2 3 1

Sample Output
2
1
3

LIS :

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
struct node
{
    int l,w;
}st[5011];
int pa[5011];//记录各个长度的尾数大小
bool cmp(node a,node b)
{
    if(a.l!=b.l)//按照长度从小到大排序
        return a.l<b.l;
    else
        return a.w<b.w; //若长度一样者按照重量从小到大排序
}
int main()
{
    int i,j;
    int T;
    int N;
    int k;
    int ml;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&N);
        for(i=0;i<N;i++)
            scanf("%d%d",&st[i].l,&st[i].w);
        sort(st,st+N,cmp);
        pa[0]=st[0].w; //初始化第一个序列的尾数
        k=1;//记录非严格递增子序列的个数
        for(i=1;i<N;i++)
        {
            ml=1;
        for(j=0;j<k;j++)
        {
            if(st[i].w>=pa[j])//更新子序列尾数
            {
                pa[j]=st[i].w;
                ml=0;
                break;
            }
        }
        if(ml)//前面所有序列的尾数都大于 st[i].w 者另开数列
            pa[k++]=st[i].w;
        }
        printf("%d\n",k);
    }
    return 0;
}

动态规划:

#include<cstdio>
#include<algorithm>
using namespace std;
struct node
{
    int l,w;
}st[5011];
bool cmp(node a,node b)
{
    if(a.l!=b.l)//按照长度从小到大排序
        return a.l<b.l;
    else
        return a.w<b.w;//若长度相同者按照重量从小到大排序
}
int pa[5011];//记录每个位置当前需要开的最小子序列
int main()
{
    int i,j;
    int T;
    int N;
    int a,b;
    int ml;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&N);
        for(i=0;i<N;i++)
            scanf("%d%d",&st[i].l,&st[i].w);
            sort(st,st+N,cmp);
            fill(pa,pa+N,1);//初始化每个位置的需要开的子序列个数为一
            ml=0;
            for(i=0;i<N;i++)
            {
                for(j=0;j<i;j++)
                {
                    if(st[i].w<st[j].w&&pa[i]<pa[j]+1)//若 i 位置的 w 小于 j 位置的 w 者需要在 j 的基础上加一 然后与之前该位置需要的子序列个数做比较取最大值
                        pa[i]=pa[j]+1;
                        if(ml<pa[i])
                            ml=pa[i];
                }
            }
            printf("%d\n",ml);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值