【LightOJ 1307 + 二分】

30 篇文章 0 订阅
24 篇文章 0 订阅

LightOJ 1307

Description
You are given N sticks having distinct lengths; you have to form some triangles using the sticks. A triangle is valid if its area is positive. Your task is to find the number of ways you can form a valid triangle using the sticks.

Input
Input starts with an integer T (≤ 10), denoting the number of test cases.

Each case starts with a line containing an integer N (3 ≤ N ≤ 2000). The next line contains N integers denoting the lengths of the sticks. You can assume that the lengths are distinct and each length lies in the range [1, 109].

Output
For each case, print the case number and the total number of ways a valid triangle can be formed.

Sample Input
3
5
3 12 5 4 9
6
1 2 3 4 5 6
4
100 211 212 121
Sample Output
Case 1: 3
Case 2: 7
Case 3: 4

#include<cstdio>
#include<algorithm>
using namespace std;
int pa[2011];
int main()
{
    int T,nl = 0,N,i,j,pl,kl,ans;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&N);
        for(i = 1 ; i <= N ; i++)
            scanf("%d",&pa[i]);
            sort(pa + 1,pa + 1 + N);
            ans = 0;
        for(i = 1 ; i <= N -2; i++)
            for(j = i + 1 ; j <= N -1; j++)//确定两边
            {
                pl = pa[i] + pa[j];
                kl = lower_bound(pa + j , pa + 1 + N ,pl) - pa; //二分查找第三边
                if(kl == j)
                    continue;
                ans += kl - j - 1;
            }
            printf("Case %d: %d\n",++nl,ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值