【Lijhtoj 1033 Generating Palindromes +最大公共子序列】

3 篇文章 0 订阅

Generating Palindromes

Description
By definition palindrome is a string which is not changed when reversed. “MADAM” is a nice example of palindrome. It is an easy job to test whether a given string is a palindrome or not. But it may not be so easy to generate a palindrome.

Here we will make a palindrome generator which will take an input string and return a palindrome. You can easily verify that for a string of length n, no more than (n - 1) characters are required to make it a palindrome. Consider “abcd” and its palindrome “abcdcba” or “abc” and its palindrome “abcba”. But life is not so easy for programmers!! We always want optimal cost. And you have to find the minimum number of characters required to make a given string to a palindrome if you are only allowed to insert characters at any position of the string.

Input
Input starts with an integer T (≤ 200), denoting the number of test cases.

Each case contains a string of lowercase letters denoting the string for which we want to generate a palindrome. You may safely assume that the length of the string will be positive and no more than 100.

Output
For each case, print the case number and the minimum number of characters required to make string to a palindrome.

Sample Input
6
abcd
aaaa
abc
aab
abababaabababa
pqrsabcdpqrs
Sample Output
Case 1: 3
Case 2: 0
Case 3: 2
Case 4: 1
Case 5: 0
Case 6: 9

实际就是找最大公共子序列裸体:

#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
char st[110];
int dp[110][110];
int main()
{
    int T,nl = 0,i,j,pl;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%s",st + 1);
        pl = strlen(st + 1);
        memset(dp,0,sizeof(dp));
        for(i = pl - 1 ; i >= 1 ; i--)
            for(j = i + 1 ; j <= pl ; j++)
        {
            if(st[i] == st[j])
                dp[i][j] = dp[i + 1][j - 1];
            else
                dp[i][j] = min(dp[i + 1][j],dp[i][j - 1]) + 1 ;
        }
        printf("Case %d: %d\n",++nl,dp[1][pl]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值