【HDU 2601 】

14 篇文章 0 订阅

Problem Description
When Teddy was a child , he was always thinking about some simple math problems ,such as “What it’s 1 cup of water plus 1 pile of dough ..” , “100 yuan buy 100 pig” .etc..

这里写图片描述
One day Teddy met a old man in his dream , in that dream the man whose name was“RuLai” gave Teddy a problem :

Given an N , can you calculate how many ways to write N as i * j + i + j (0 < i <= j) ?

Teddy found the answer when N was less than 10…but if N get bigger , he found it was too difficult for him to solve.
Well , you clever ACMers ,could you help little Teddy to solve this problem and let him have a good dream ?

Input
The first line contain a T(T <= 2000) . followed by T lines ,each line contain an integer N (0<=N <= 1010).

Output
For each case, output the number of ways in one line.

Sample Input
2
1
3

Sample Output
0
1

不难想到 i * j + i +j = (i + 1) * (j + 1) - 1 = N,既N + 1 = (i + 1) * (j + 1),只用判断 N + 1 是否能整除 i + 1 就好因为 j >= i,所以只用判断到 根号 N +1就好

AC代码 :

#include<cstdio>
#include<cmath>
using namespace std;
int main()
{
    int T,i,ans;
    long long sum,N;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%lld",&N);
        sum = N + 1;
        ans = 0;
        N = sqrt(sum * 1.0);
        for(i = 2 ; i <= N; i++)
            if(sum % i == 0)
             ans++;
        printf("%d\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值