【玲珑学院 1057 - Private Value】+ map

1057 - Private Value

Time Limit:1s Memory Limit:128MByte

Submissions:511Solved:165
DESCRIPTION

The “private value” is the value that occurs, but most infrequent.

An array of integers is given, and you need print the private values of the array.

Please notice that, there might be several private values, and you need print them in increasing order.

INPUT
The first line is an integer T(1 <= T <= 4), indicating the number of test cases.
For each case, the first line contains an integer n (n <= 100000).
The second line contains n integers a_i (0 <= a_i <= 10^9),
OUTPUT
For each case, print all private values in increasing order in a line.
SAMPLE INPUT
2
7
1 1 2 2 3 3 3
5
5 3 2 4 1
SAMPLE OUTPUT
1 2
1 2 3 4 5

map~映射~~

#include<cstdio>
#include<map>
#include<algorithm>
using namespace std;
const int MAXN = 100010;
map <int,int> m;
int ma[MAXN];
int main()
{
    int T,n;
    scanf("%d",&T);
    while(T--){
        scanf("%d",&n);
        for(int i = 1 ; i <= n ; i++){
            scanf("%d",&ma[i]);
            m[ma[i]]++;
        }
        sort(ma + 1, ma + 1 + n);
        int minn = 1e8;
        for(int i = 1 ; i <= n ; i++)
            minn = min(minn,m[ma[i]]);
        int ok = 0;
        for(int i = 1 ; i <= n ; i++){
            if(m[ma[i]] == minn){
                if(ok) printf(" ");
                printf("%d",ma[i]);
                ok = 1;
            }
            m[ma[i]] = 0; // 每次用过后清空 
        }
        printf("\n");
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值