【HDU 6000 Wash】优先队列 & 贪心

34 篇文章 0 订阅
26 篇文章 0 订阅

Wash

Time Limit: 20000/10000 MS (Java/Others) Memory Limit: 64000/64000 K (Java/Others)
Total Submission(s): 1076 Accepted Submission(s): 283

Problem Description
Mr.Panda is about to engage in his favourite activity doing laundry! He’s brought L indistinguishable loads of laundry to his local laundromat, which has N washing machines and M dryers.The ith washing machine takes Wi minutes to wash one load of laundry, and the ith dryer takes Di minutes to dry a load of laundry.
At any point in time, each machine may only be processing at most one load of laundry.
As one might expect, Panda wants to wash and then dry each of his L loads of laundry. Each load of laundry will go through the following steps in order:
1. A non-negative amount of time after Panda arrives at the laundromat, Panda places the load in an unoccupied washing machine i.
2. Wi minutes later, he removes the load from the washing machine, placing it in a temporary holding basket (which has unlimited space)
3. A non-negative amount of time later, he places the load in an unoccupied dryer j
4. Dj minutes later, he removes the load from the dryer Panda can instantaneously add laundry to or remove laundry from a machine. Help Panda minimize the amount of time (in minutes after he arrives at the laundromat) after which he can be done washing and drying all L loads of laundry!

Input
The first line of the input gives the number of test cases, T.
T test cases follow. Each test case consists of three lines. The first line contains three integer L, N, and M.
The second line contains N integers W1,W2,…,WN representing the wash time of each wash machine.
The third line contains M integers D1,D2,…,DM representing the dry time of each dryer.

Output
For each test case, output one line containing “Case #x: y”, where x is the test case number (starting from 1) and y is the minimum time it will take Panda to finish his laundry.
limits

∙1≤T≤100.
∙1≤L≤106.
∙1≤N,M≤105.
∙1≤Wi,Di≤109.

Sample Input
2
1 1 1
1200
34
2 3 2
100 10 1
10 10

Sample Output
Case #1: 1234
Case #2: 12

Source
2016 CCPC-Final

Recommend
jiangzijing2015 | We have carefully selected several similar problems for you: 6216 6215 6214 6213 6212

题意 : N 台洗衣机,M 台烘干机,把 L 件衣服洗完烘干最少需要多少时间

思路 : 洗完每件衣服的最短时间可以用优先队列保存,并记录下来,然后再用优先队列处理烘干机,贪心,对于最后一个洗完的衣服让烘干最快的烘干机去烘干

AC代码:

#include<cstdio>
#include<cmath>
#include<deque>
#include<queue>
#include<vector>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAX = 1e6 + 10;
const int INF = 1e9 + 7;
typedef long long LL;
#define p pair<LL,LL>
priority_queue <p,vector<p>,greater<p> > q;
LL t[MAX];
int main()
{
    int T,nl = 0;
    scanf("%d",&T);
    while(T--){
        while(!q.empty())
            q.pop();
        int L,N,M;
        LL x;
        p w;
        scanf("%d %d %d",&L,&N,&M);
        for(int i = 1; i <= N; i++){
            scanf("%lld",&x);
            q.push(p(x,x));
        }
        for(int i = 1; i <= L; i++){
            w = q.top();
            q.pop();
            t[i] = w.first;
            q.push(p(w.first + w.second,w.second));
        }
        while(!q.empty())
            q.pop();
        for(int i = 1; i <= M; i++){
            scanf("%lld",&x);
            q.push(p(x,x));
        }
        LL ans = 0;
        for(int i = L; i >= 1; i--){
            w = q.top();
            q.pop();
            ans = max(ans,t[i] + w.first);
            q.push(p(w.first + w.second,w.second));
        }
        printf("Case #%d: %lld\n",++nl,ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值