数据结构实验之栈二:一般算术表达式转换成后缀式


Problem Description
对于一个基于二元运算符的算术表达式,转换为对应的后缀式,并输出之。
Input
输入一个算术表达式,以‘#’字符作为结束标志。
Output
输出该表达式转换所得到的后缀式。
Example Input
a*b+(c-d/e)*f#
Example Output
ab*cde/-f*+


#include <iostream>
#include <algorithm>
#include <cstdio>
using namespace std;
typedef struct
{
    char *top,*base;
} _stack;

void _stackinitial(_stack &s)
{
    s.base=(char *)malloc(1000*sizeof(int));
    s.top=s.base;
}

void push(_stack &s,char e)
{
    *s.top++=e;
}

char top(_stack &s)
{
    return *(s.top-1);
}

void pop(_stack &s)
{
    s.top--;
}

int em(_stack &s)
{
    if(s.base==s.top) return 1;
    else return 0;
}

int main()
{
    _stack s;
    _stackinitial(s);
    char str[110];
    int i;
    scanf("%s",str);
    for(i=0; str[i]!='#'; i++)
    {
        if(str[i]>='a'&&str[i]<='z') printf("%c",str[i]);
        else if(str[i]=='(') push(s,str[i]);
        else if(str[i]==')')
        {
            while(top(s)!='(')
            {
                printf("%c",top(s));
                pop(s);
            }
            pop(s);
        }
        else if(str[i]=='+'||str[i]=='-')
        {
            while(!em(s)&&top(s)!='(')
            {
                printf("%c",top(s));
                pop(s);
            }
            push(s,str[i]);
        }
        else if(str[i]=='*'||str[i]=='/')
        {
            while(!em(s)&&top(s)!='('&&(top(s)=='*'||top(s)=='/'))
            {
                printf("%c",top(s));
                pop(s);
            }
            push(s,str[i]);
        }
    }
    while(!em(s))
    {
        printf("%c",top(s));
        pop(s);
    }
    printf("\n");
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值