Message Flood

Problem Description
Well, how do you feel about mobile phone? Your answer would probably be something like that "It's so convenient and benefits people a lot". However, If you ask Merlin this question on the New Year's Eve, he will definitely answer "What a trouble! I have to keep my fingers moving on the phone the whole night, because I have so many greeting message to send!" Yes, Merlin has such a long name list of his friends, and he would like to send a greeting message to each of them. What's worse, Merlin has another long name list of senders that have sent message to him, and he doesn't want to send another message to bother them Merlin is so polite that he always replies each message he receives immediately). So, before he begins to send message, he needs to figure to how many friends are left to be sent. Please write a program to help him. Here is something that you should note. First, Merlin's friend list is not ordered, and each name is alphabetic strings and case insensitive. These names are guaranteed to be not duplicated. Second, some senders may send more than one message to Merlin, therefore the sender list may be duplicated. Third, Merlin is known by so many people, that's why some message senders are even not included in his friend list.
Input
There are multiple test cases. In each case, at the first line there are two numbers n and m (1<=n,m<=20000), which is the number of friends and the number of messages he has received. And then there are n lines of alphabetic strings(the length of each will be less than 10), indicating the names of Merlin's friends, one per line. After that there are m lines of alphabetic strings, which are the names of message senders. The input is terminated by n=0.
Output
For each case, print one integer in one line which indicates the number of left friends he must send.
Example Input
5 3
Inkfish
Henry
Carp
Max
Jericho
Carp
Max
Carp
0
Example Output
3


#include <cstdio>
#include <string>
#include <cstring>
#include <queue>
#include <map>
#include<algorithm>
using namespace std;

int main()
{
  map<string,int> mp;
  int n, m, i, len, j;
  char s[30];
  while(~scanf("%d",&n)&&n)
  {
      scanf("%d\n",&m);
    mp.clear();      //如果在外面定义的话要注意清空。
    for(i=0;i<n;i++)
    {
      gets(s);
      len=strlen(s);
      for(j=0;j<len;j++)
      {
        s[j]=tolower(s[j]);//tolower函数将大写字母转换成小写字母
      }
      mp[s]++;
    }
    for(i=0;i<m;i++)
    {
      gets(s);
      len=strlen(s);
      for(j=0;j<len;j++)
      {
        s[j]=tolower(s[j]);
      }
      mp.erase(s);//erase函数在该容器中删除该元素
    }
    printf("%d\n",mp.size());//直接用size函数输出容器内元素的个数。
  }
  return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值