数据结构实验之二叉树八:(中序后序)求二叉树的深度

Problem Description

已知一颗二叉树的中序遍历序列和后序遍历序列,求二叉树的深度。

Input

输入数据有多组,输入T,代表有T组数据。每组数据包括两个长度小于50的字符串,第一个字符串表示二叉树的中序遍历,第二个表示二叉树的后序遍历。

Output

输出二叉树的深度。

Sample Input
2
dbgeafc
dgebfca
lnixu
linux
Sample Output
4

3

#include <bits/stdc++.h>
using namespace std;

typedef struct tnode{
    char data;
    struct tnode *lc,*rc;
}tnode,*tree;

tree create(char in[],char post[],int n)
{
    int i;
    tree t;
    if(!n) return NULL;
    for(i=0;i<n;i++){
        if(post[n-1]==in[i]) break;
    }
    t=new(tnode);
    t->data=post[n-1];
    t->lc=create(in,post,i);
    t->rc=create(in+i+1,post+i,n-i-1);
    return t;
}

int depth(tree t)
{
    int d,l,r;
    if(!t) d=0;
    else{
        l=depth(t->lc);
        r=depth(t->rc);
        d=1+(l>r?l:r);
    }
    return d;
}

int main()
{
    int n;
    cin>>n;
    char a[55],b[55];
    while(n--){
        cin>>a>>b;
        tree t;
        t=create(a,b,strlen(a));
        cout<<depth(t);
        cout<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值