The Mountain

All as we know, a mountain is a large landform that stretches above the surrounding land in a limited area. If we as the tourists take a picture of a distant mountain and print it out, the image on the surface of paper will be in the shape of a particular polygon.

From mathematics angle we can describe the range of the mountain in the picture as a list of distinct points, denoted by (x_1,y_1)(x  1 ​  ,y  1 ​  ) to (x_n,y_n)(x  n ​  ,y  n ​  ). The first point is at the original point of the coordinate system and the last point is lying on the xx-axis. All points else have positive y coordinates and incremental xx coordinates. Specifically, all x coordinates satisfy 0 = x_1 < x_2 < x_3 < ... < x_n0=x  1 ​  <x  2 ​  <x  3 ​  <...<x  n ​  . All yy coordinates are positive except the first and the last points whose yy coordinates are zeroes.

The range of the mountain is the polygon whose boundary passes through points (x_1,y_1)(x  1 ​  ,y  1 ​  ) to (x_n,y_n)(x  n ​  ,y  n ​  ) in turn and goes back to the first point. In this problem, your task is to calculate the area of the range of a mountain in the picture.

Input  

The input has several test cases and the first line describes an integer t (1 \le t \le 20)t(1≤t≤20) which is the total number of cases.  In each case, the first line provides the integer n (1 \le n \le 100)n(1≤n≤100) which is the number of points used to describe the range of a mountain. Following nn lines describe all points and the ii-th line contains two integers x_ix  i ​   and y_i (0 \le x_i, y_i \le 1000)y  i ​  (0≤x  i ​  ,y  i ​  ≤1000) indicating the coordinate of the ii-th point.

样例输入  3 3 0 0 1 1 2 0 4 0 0 5 10 10 15 15 0 5 0 0 3 7 7 2 9 10 13 0

样例输出  

1.000000

125.000000

60.500000 

比赛的题目只能写写水题(也蛮开心的),这题大意就是在笛卡尔坐标系里面画一个折线图求所占面积,没有什么特别的就输入一个计算一下与前面点连接占的面积,主要就是加上一个三角形面积后加的矩形面积要根据于前一点的高低比较得来。

#include<bits/stdc++.h>
using namespace std;
int main(){
    int n;
    cin >> n;
    while(n--){
        int m,x,y,bx = 0,by = 0,flag = 1;
        double ans = 0;
        cin >> m;
        while(m--){
            cin >> x >> y;
            if(flag){
             	flag = 0;
            	continue;   
            }
            ans += (x - bx)*abs(y - by)*1.0/2.0;
            if(y >= by && by != 0){
                ans += (x - bx)*by*1.0;
            }
            if(y < by && y > 0){    
                ans += (x - bx)*y*1.0;
            }
            bx = x, by = y;
        }
        printf("%.6f\n",ans);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值