P1040 加分二叉树

题目描述

设一个 nn 个节点的二叉树tree的中序遍历为( 1,2,3,…,n1,2,3,…,n ),其中数字 1,2,3,…,n1,2,3,…,n 为节点编号。每个节点都有一个分数(均为正整数),记第 ii 个节点的分数为 di,treedi,tree 及它的每个子树都有一个加分,任一棵子树 subtreesubtree (也包含 treetree 本身)的加分计算方法如下:

subtreesubtree 的左子树的加分× subtreesubtree 的右子树的加分+ subtreesubtree 的根的分数。

若某个子树为空,规定其加分为 11 ,叶子的加分就是叶节点本身的分数。不考虑它的空子树。

试求一棵符合中序遍历为( 1,2,3,…,n1,2,3,…,n )且加分最高的二叉树 treetree 。要求输出;

(1) treetree 的最高加分

(2) treetree 的前序遍历

输入输出格式

输入格式:

 

第 11 行: 11 个整数 n(n<30)n(n<30) ,为节点个数。

第 22 行: nn 个用空格隔开的整数,为每个节点的分数(分数 <100<100 )。

 

输出格式:

 

第 11 行: 11 个整数,为最高加分(Ans \le 4,000,000,000≤4,000,000,000 )。

第 22 行: nn 个用空格隔开的整数,为该树的前序遍历。

 

输入输出样例

输入样例#1: 复制

5
5 7 1 2 10

输出样例#1: 复制

145
3 1 2 4 5

 只过了样例,看题解dalao都是dp,先存一下以后继续改。。

#include<iostream>
#include<algorithm>
using namespace std;
int ans = 0;
struct node{
	int score,left = -1,right = -1;
}; 
node tree[30];
void dfs(int x, int l, int r){
	//cout << x << " " << l << " " << r <<endl;
	int m = 100,k;
	if(x > l){
		for(int i = l; i < x; i ++){
			if(m > tree[i].score){
				m = tree[i].score;
				k = i;
			}
		}
		tree[x].left = k;
		dfs(k,l,x-1);
	}
	m = 100; 
	if(x < r){
		for(int i = x+1; i <= r; i ++){
			if(m > tree[i].score){
				m = tree[i].score;
				k = i;
			}
		}
		tree[x].right = k;
		dfs(k,x+1,r);
	}
}
void print(int x){
	cout << x+1 << " ";
	if(tree[x].left != -1)
		print(tree[x].left);
	if(tree[x].right != -1)
		print(tree[x].right);
}
void treesum(int x){
	int l,r;
	l = tree[x].left;
	r = tree[x].right;
	if(tree[x].left != -1)
	{
		treesum(tree[x].left); 
		l = tree[l].score;
	}
	else
		l = 1;
	if(tree[x].right != -1)
	{
		treesum(tree[x].right);
		r = tree[r].score;
	} 
	else
		r = 1;
	if(r != 1 || l != 1)		
		tree[x].score = tree[x].score + l * r; 
	//cout <<x <<" "<< l<<'<' << tree[x].score << '>' <<r<< endl;
	//ans +=  tree[x].score; 
}
int main(){
	int n,min = 100,minx;
	cin >> n;
	for(int i = 0; i < n; i ++){
		cin >> tree[i].score;
		if(min > tree[i].score){
			min = tree[i].score;
			minx = i;
		}
	}
	dfs(minx,0,n-1);
	//for(int i = 0; i < n; i ++)
	//	cout << i << " " << tree[i].left << " " << tree[i].right << endl;
	treesum(minx);
	cout << tree[minx].score << endl;
	print(minx);
	
	return 0;
} 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值