CA Loves Stick HDU - 5655

题目大意:意思非常简单,就是给你四个木棒,是否能用这四个木棒拼成一个四边形

解题思路:只需要判断最小的三条边的和是否大于第四条边就行了。但是数据给的最大是long long int,所以不能直接比较,转化一下,还有需要判断木棒中 不能有0

CA loves to play with sticks. 
One day he receives four pieces of sticks, he wants to know these sticks can spell a quadrilateral. 
(What is quadrilateral? Click here: https://en.wikipedia.org/wiki/Quadrilateral)
Input
First line contains  T T denoting the number of testcases. 
T T testcases follow. Each testcase contains four integers  a,b,c,d a,b,c,d in a line, denoting the length of sticks. 
1T1000, 0a,b,c,d2631 1≤T≤1000, 0≤a,b,c,d≤263−1
Output
For each testcase, if these sticks can spell a quadrilateral, output "Yes"; otherwise, output "No" (without the quotation marks).
Sample Input
2
1 1 1 1
1 1 9 2
Sample Output
Yes
No


#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
long long int a[5];
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int f1,f2,f3,f4,f5,f6;
        for(int i=0;i<4;i++)
        scanf("%lld",&a[i]);
        sort(a,a+4);  //从小到大排序
        if(a[0]==0)  //有0 肯定不能组成四边形
        {
            printf("No\n");
            continue;
        }
        if(a[0]>a[3]-a[1]-a[2])  //判断最小的三条边是否大于第四条边
            printf("Yes\n");
        else
            printf("No\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值