poj 2559 Largest Rectangle in a Histogram

题目大意:给你一个柱状图,每个矩形的宽度都是1,问你在柱状图中可以截取的最大的矩形的面积是多大


解题思路:分别以每一个矩形的高度为最小值,找出每一个单位矩形的左边界和右边界的下标,左边界(left)定义为:左边连续比当前高度大的最左边的单位矩形的下标,右边界(right)定义为:右边连续比当前高度大的最右边的单位矩形的下标。然后用(右边界-左边界+1)*dp[i](当前矩形的高度),就可以得出分别以每个矩形为最小值的最大矩形面积

 Largest Rectangle in a Histogram

 
A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles: 
 
Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.
Input
The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1 <= n <= 100000. Then follow n integers h1, ..., hn, where 0 <= hi <= 1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.
Output
For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.
Sample Input
7 2 1 4 5 1 3 3
4 1000 1000 1000 1000
0
Sample Output
8
4000

#include<stdio.h>
#include<string.h>
const int N=100000+10;
long long dp[N],left[N],right[N],maxn,t;
int main()
{
    int n;
    while(~scanf("%d",&n),n)
    {
        for(int i=1;i<=n;i++)
            scanf("%I64d",&dp[i]);
        left[1]=1;
        right[n]=n;
        for(int i=2;i<=n;i++)
        {
            t=i;
            while(t>1&&dp[i]<=dp[t-1])  //找当前矩形左边能延伸到的矩形的下标
                t=left[t-1];
            left[i]=t;
           // printf("%d /*/*/*\n",left[i]);
        }
        for(int i=n-1;i>=1;i--)
        {
            t=i;
            while(t<n&&dp[i]<=dp[t+1])//找当前矩形右边能延伸到的矩形的下标
                t=right[t+1];
            right[i]=t;
            //printf("%d ++++++\n",right[i]);
        }
        maxn=0;
        for(int i=1;i<=n;i++)
        {
            long long l=(right[i]-left[i]+1)*dp[i];
            if(l>maxn)
                maxn=l;
        }
        printf("%I64d\n",maxn);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值