问题:
实现一个“猜数字”的游戏。给定答案序列和用户猜的序列,统计有多少数字位置正确(A),有多少数字在两个序列都出现过但位置不对(B)。输入包含多组数据,每组输入第一行为序列长度n,第二行是答案序列,接下来是若干行猜测序列。猜测序列全0时该数据结束。n=0时输入结束。
样例输入:
4
1 3 5 5
1 1 2 3
4 3 3 5
6 5 5 1
6 1 3 5
1 3 5 5
0 0 0 0
样例输出:
Game 1:
(1,1)
(2,0)
(1,2)
(1,2)
(4,0)
#include<iostream>
using namespace std;
const int maxn = 1010;
int main(){
int a[maxn],b[maxn];
int A,B,n,cases = 0;
while(scanf("%d", &n) == 1 && n){
printf("Game %d:\n", ++cases);
for(int i=0;i<n;i++){
scanf("%d", &a[i]);
}
while(true){
B = 0;
A = 0;
for(int j=0;j<n;j++){
scanf("%d", &b[j]);
if(a[j] == b[j])
A++;
}
if(b[0] == 0)
break;
int c1,c2;
for(int d=1;d<9;d++){
c1 = 0;
c2 = 0;
for(int j=0;j<n;j++){
if(a[j] == d)
c1++;
if(b[j] == d)
c2++;
}
B += c1<c2?c1:c2;
}
printf("(%d,%d)\n", A, B - A);
}
}
return 0;
}
}