ACM暑假集训_STL&模拟_H-Compound Words

ACM暑假集训_STL&模拟_H-Compound Words

Description

You are to find all the two-word compound words in a dictionary. A two-word compound word is a word in the dictionary that is the concatenation of exactly two other words in the dictionary.

Input

Standard input consists of a number of lowercase words, one per line, in alphabetical order. There will be no more than 120,000 words.

Output

Your output should contain all the compound words, one per line, in alphabetical order.

Sample Input

a

alien

born

less

lien

never

nevertheless

new

newborn

the

zebra

Sample Output

alien

newborn

Hint

 

解题思路

把每个单词可能的拆分结果都枚举一遍,判断是否在“字典”里存在。

代码

#include <set>
#include <iostream>
using namespace std;
set<string>s;
int main() 
{
	string w;
	while(cin>>w) 
	{
		s.insert(w);
	}
	set<string>::iterator it; 
	for(it=s.begin();it!=s.end();it++) 
	{
		for(int i=1;i<(*it).size();i++) 
		{
			string head=(*it).substr(0,i);
			string foot=(*it).substr(i);
			if(s.count(head)&&s.count(foot)) 
			{
				cout <<(*it)<<endl;
				break;
			}
		}
	}
	return 0;
}
 

 

 

 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值