POJ - 3259 Wormholes(SPFA最短路判断负环)

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input
Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2.. M+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2.. M+ W+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.
Output
Lines 1.. F: For each farm, output “YES” if FJ can achieve his goal, otherwise output “NO” (do not include the quotes).
Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint
For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

题目大意:N个区域标号1—N, 之间有M条路(无向),W个虫洞(有向),后面M行输入无向路S到E耗时T, 再后面W行输入虫洞S到E时间倒退T。问是否可以从1号点出发最终回到起点且时间退回到出发时间之前。

大体思路:SPFA求最短路判断负环问题, 只要负环存在,就一定能不断的回到出发点且回退到出发的时间之前。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <queue>
#define N 600
#define INF 0x3f3f3f3f
using namespace std;
struct node
{
    int to;
    int w;
}tmp;
vector <node> Map[N];
int dis[N];
bool vis[N];
bool SPFA(int s);
int n, m, w;

int main()
{
    int t;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%d%d%d", &n, &m, &w);
        int u, v, c;
        for(int i = 0; i < m; i++)//建无向图
        {
            scanf("%d%d%d", &u, &v, &c);
            tmp.to = v;
            tmp.w = c;
            Map[u].push_back(tmp);
            tmp.to = u;
            Map[v].push_back(tmp);
        }
        for(int i = 0; i < w; i++)//虫洞时间取负值
        {
            scanf("%d%d%d", &u, &v, &c);
            tmp.to = v;
            tmp.w = -c;
            Map[u].push_back(tmp);
        }
        if(SPFA(1))
        {
            printf("YES\n");
        }
        else
        {
            printf("NO\n");
        }
        for(int  i = 0; i <= n; i++)
        {
            Map[i].clear();
        }
    }
    return 0;
}
bool SPFA(int s)
{
    int cnt[N] = {0};
    memset(vis, false, sizeof(vis));
    memset(dis, INF, sizeof(dis));
    dis[s] = 0;
    vis[s] = true;
    queue <int> q;
    q.push(s);
    cnt[s] ++;
    while(!q.empty())
    {
        int u = q.front();
        //if(cnt[u] >= n)
        //return true;//判断负环有两张方法,这种是判断每个点入队次数超过N次, 则证明有负环(但实测比下面那种方法慢)
        q.pop();
        vis[u] = false;
        int _end = Map[u].size();
        for(int i = 0; i < _end; i++)
        {
            int to = Map[u][i].to;
            if(dis[to] > dis[u] + Map[u][i].w)
            {
                dis[to] = dis[u] + Map[u][i].w;
                if(dis[1] < 0)
                return true;//判断负环方法第二种,若起始点dis[S] < 0, 则证明出现负环
                if(!vis[to])
                {
                    vis[to] = true;
                    q.push(to);
                    cnt[to]++;
                }
            }
        }
    }
    return false;//不存在负环, 返回false
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值