HDU4027 Can you answer these queries? (线段树单点更新 +优化)

Problem Description
A lot of battleships of evil are arranged in a line before the battle. Our commander decides to use our secret weapon to eliminate the battleships. Each of the battleships can be marked a value of endurance. For every attack of our secret weapon, it could decrease the endurance of a consecutive part of battleships by make their endurance to the square root of it original value of endurance. During the series of attack of our secret weapon, the commander wants to evaluate the effect of the weapon, so he asks you for help.
You are asked to answer the queries that the sum of the endurance of a consecutive part of the battleship line.

Notice that the square root operation should be rounded down to integer.

Input
The input contains several test cases, terminated by EOF.
For each test case, the first line contains a single integer N, denoting there are N battleships of evil in a line. (1 <= N <= 100000)
The second line contains N integers Ei, indicating the endurance value of each battleship from the beginning of the line to the end. You can assume that the sum of all endurance value is less than 263.
The next line contains an integer M, denoting the number of actions and queries. (1 <= M <= 100000)
For the following M lines, each line contains three integers T, X and Y. The T=0 denoting the action of the secret weapon, which will decrease the endurance value of the battleships between the X-th and Y-th battleship, inclusive. The T=1 denoting the query of the commander which ask for the sum of the endurance value of the battleship between X-th and Y-th, inclusive.

Output
For each test case, print the case number at the first line. Then print one line for each query. And remember follow a blank line after each test case.

Sample Input

10
1 2 3 4 5 6 7 8 9 10
5
0 1 10
1 1 10
1 1 5
0 5 8
1 4 8

Sample Output

Case #1:
19
7
6

题目大意:给你n个数字和q次操作, 操作编号1为询问区间[l,r]的数字加和, 操作编号0为将区间[l, r]的数字取平方根(取整)。
思路:线段树区间更新是行不通的,只能进行单点更新。前面几发单点更新直接TLE,  后来发现得优化:即使一个很大的数字取几次平方根后就会变的很小,当值变为1时就没有继续取根的必要了,所以只要标记出权值为1的区间,以后就不用更新了。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#define N 100100
using namespace std;
struct node
{
    long long val;
    bool flag;//标记区间
} segtree[N << 2];
void build(long long node, long long s, long long e);
long long a[N << 2];
long long query(long long node, long long s, long long e, long long l, long long r);
void updata(long long node, long long s, long long e, long long l, long long r);
int main()
{
    int n;
    int kase = 0;
    while(scanf("%d", &n) == 1 && n)
    {
        for(int i = 1; i <= n; i++)
        {
            scanf("%lld", &a[i]);
        }
        build(1, 1, n);
        int q;
        scanf("%d", &q);
        printf("Case #%d:\n", ++kase);
        long long t, x, y;
        while(q--)
        {
            scanf("%lld%lld%lld", &t, &x, &y);
            if(x > y)
                swap(x, y);
            if(!t)
            {
                updata(1, 1, n, x, y);
            }
            else
            {
                printf("%lld\n",query(1, 1, n, x, y));
            }
        }
        printf("\n");
    }
    return 0;
}
void build(long long node, long long s, long long e)
{
    segtree[node].flag = 0;
    if(s == e)
    {
        segtree[node].val = a[s];
        if(a[s] <= 1)
        {
            segtree[node].flag = true;
        }
        return;
    }
    int mid = (s + e) >> 1;
    build(node << 1, s, mid);
    build(node << 1 | 1, mid + 1, e);
    segtree[node].val = segtree[node << 1].val + segtree[node << 1 | 1].val;
    if(segtree[node].val  == (e - s + 1))//如果区间和为区间长度,则区间里的值就都为1
        segtree[node].flag = 1;//将其标记
    else segtree[node].flag = 0;
}
long long query(long long node, long long s, long long e, long long l, long long r)
{
    if(s >= l && e <= r)
    {
        return segtree[node].val;
    }
    if(s > r || e < l)
    {
        return 0;
    }
    int mid = (s + e) >> 1;
    return query(node << 1, s, mid, l, r) + query(node << 1 | 1, mid + 1, e, l, r);
}
void updata(long long node, long long s, long long e, long long l, long long r)
{
    if(s == e)
    {
        segtree[node].val = sqrt(1.0 * segtree[node].val);
        if(segtree[node].val == 1)//判断标记
        {
            segtree[node].flag = 1;
        }
        return;
    }
    int mid = (s + e ) >> 1;
    if(mid >= l && !segtree[node << 1].flag)
    {
        updata(node << 1, s, mid, l, r);
    }
    if(mid < r && !segtree[node << 1 | 1].flag)
    {
        updata(node << 1 |1, mid + 1, e, l, r);
    }
    segtree[node].val = segtree[node << 1].val + segtree[node << 1 | 1].val;
    if(segtree[node].val  == (e - s + 1))//同build函数作用
    {
        segtree[node].flag = 1;
    }
    else segtree[node].flag = 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值