SDUT 3324顺序表应用1:多余元素删除之移位算法(线性表)

Time Limit: 1000MS Memory Limit: 650KB
Submit Statistic
Problem Description

一个长度不超过10000数据的顺序表,可能存在着一些值相同的“多余”数据元素(类型为整型),编写一个程序将“多余”的数据元素从顺序表中删除,使该表由一个“非纯表”(值相同的元素在表中可能有多个)变成一个“纯表”(值相同的元素在表中只保留第一个)。
要求:
1、必须先定义线性表的结构与操作函数,在主函数中借助该定义与操作函数调用实现问题功能;
2、本题的目标是熟悉顺序表的移位算法,因此题目必须要用元素的移位实现删除;
Input

第一行输入整数n,代表下面有n行输入;
之后输入n行,每行先输入整数m,之后输入m个数据,代表对应顺序表的每个元素。
Output

输出有n行,为每个顺序表删除多余元素后的结果
Example Input

4
5 6 9 6 8 9
3 5 5 5
5 9 8 7 6 5
10 1 2 3 4 5 5 4 2 1 3
Example Output

6 9 8
5
9 8 7 6 5
1 2 3 4 5
题目很简单, 这不是重点, 重点是我要使用class封装一遍。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;
const int Maxnum = 10100;
typedef int Elemtype;
class List
{
public:
    void Initi();//初始化操作
    void Del(int idx);//删除元素
    int Lenth();//返回长度
    Elemtype At(int n);//返回下标为n的元素
private:
    Elemtype Data[Maxnum];
    int lenth;

};
typedef List* ListP;
void List::Initi()
{
    int n;
    cin >> n;
    lenth = n;
    for(int i = 0; i < n; i++)
    {
        scanf("%d", &Data[i]);
    }
}
void List::Del(int idx)
{
    for(int i = idx; i < lenth - 1; i++)
    {
        Data[i] = Data[i + 1];
    }
    lenth--;
}
Elemtype List::Lenth()
{
    return lenth;
}
int List::At(int n)
{
    return Data[n];
}
int main()
{
    int t;
    cin >> t;
    while(t--)
    {
        List L;
        L.Initi();
        for(int i = 0; i < L.Lenth(); i++)
        {
            int j = i + 1;
            while(j < L.Lenth())
            {
                if(L.At(i) == L.At(j))
                {
                    L.Del(j);
                }
                else
                    j++;
            }
        }
        for(int i = 0; i < L.Lenth(); i++)
        {
            printf("%d%c", L.At(i), i == L.Lenth() - 1 ? '\n' : ' ');
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值