动规:Investment

杭师 1136-Investment

附上链接


题目描述:
John never knew he had a grand-uncle, until he received the notary’s letter. He learned that his late grand-uncle had gathered a lot of money, somewhere in South-America, and that John was the only inheritor. John did not need that much money for the moment. But he realized that it would be a good idea to store this capital in a safe place, and have it grow until he decided to retire. The bank convinced him that a certain kind of bond was interesting for him.

This kind of bond has a fixed value, and gives a fixed amount of yearly interest, payed to the owner at the end of each year. The bond has no fixed term. Bonds are available in different sizes. The larger ones usually give a better interest. Soon John realized that the optimal set of bonds to buy was not trivial to figure out. Moreover, after a few years his capital would have grown, and the schedule had to be re-evaluated.

Assume the following bonds are available:

Value Annual interest
4000 400
3000 250
With a capital of 10 000 one could buy two bonds of 4 000, giving a yearly interest of 800. Buying two bonds of 3 000, and one of 4 000 is a better idea, as it gives a yearly interest of 900. After two years the capital has grown to 11 800, and it makes sense to sell a 3 000 one and buy a 4 000 one, so the annual interest grows to 1 050. This is where this story grows unlikely: the bank does not charge for buying and selling bonds. Next year the total sum is 12 850, which allows for three times 4 000, giving a yearly interest of 1 200.

Here is your problem: given an amount to begin with, a number of years, and a set of bonds with their values and interests, find out how big the amount may grow in the given period, using the best schedule for buying and selling bonds.

输入
The first line contains a single positive integer N which is the number of test cases.

The test cases follow.

The first line of a test case contains two positive integers: the amount to start with (at most 1 000 000), and the number of years the capital may grow (at most 40).

The following line contains a single number: the number d (1 <= d <= 10) of available bonds.

The next d lines each contain the description of a bond. The description of a bond consists of two positive integers: the value of the bond, and the yearly interest for that bond. The value of a bond is always a multiple of $1 000. The interest of a bond is never more than 10% of its value.

输出
For each test case, output – on a separate line – the capital at the end of the period, after an optimal schedule of buying and selling.

样例输入

1
10000 4
2
4000 400
3000 250

样例输出

14050


题目的意思是,有个人发财了,然后他想把钱用来买债券投资,并在过一年后把本钱和利息一起进行新一轮的投资。给出当前的债券信息和想要投资的年数,问他最终会有多少钱。
其实看懂题目会发现这道题就是一道背包问题,但好像数据有点大哈。。。找找题目中有什么可以用的信息,你会发现给的债券都是1000的整数倍。有这句话就可以化简数据量了。可能大家还不知道哪里可以化简,那首先让我们从另一个角度来看动规:就比如题目描述中给的数据,会发现在第一年中4000,4000的分配没有3000,3000,4000的方式好,因为前一种分配方式还有2000没有用,而后一种方式已经全部用上了。如果我们将初始的钱改为10005或10050或10500,我们都会发现上面最优的分配方式还是没变。这是因为3000的倍数和4000的倍数的差值最小为1000,就是说如果没有利用的钱超过1000了,就有可能会存在一种更优的情况来替代原来的方案。但是如果没有利用的钱数没有超过1000,那么我们就可以直接忽视它,因为会发生最优情况会变化的钱数一定是在1000的倍数上产生的。
想到这里,那这道题就简单了,把原始的钱数和债券都同时缩小1000倍,就是完全的背包问题了。同时别忘了在每次循环的开始时加上上一年的利息再缩小1000。
另外,这道题还有一个巨坑,害得我SF好多次,就是dp数组不能按原始钱数缩小1000倍来开,虽然最初的钱数是肯定小于1000000的,但是没法保证在每次dp完了的时候不会超过1000000不多,大概开到45000左右就行了吧,当然多开一点更保险。
附上代码:

#include<iostream>
#include<string>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<cstdio>
#include<cstdlib>
#include<cctype>
using namespace std;
int main(){
    ios::sync_with_stdio(0);
    int t, year, n;
    long long ini;
    cin >> t ;
    while( t-- ){
        long long w[15], v[15], dp[50000];
        cin >> ini >> year >> n;
        long long save = ini;
        ini /= 1000;
        for( int i=0 ; i<n ;i++ ){
            cin >> w[i] >> v[i];
            w[i] /= 1000;
        }
        while( year-- ){
            memset( dp, 0, sizeof(dp));
            for( int i=0 ; i<=ini ; i++ ){
                for( int j=0 ; j<n ; j++ ){
                    if( i>=w[j] )
                     dp[i] = max( dp[i], dp[i-w[j]]+v[j] );
                }
            }
            save += dp[ini];
            ini = save/1000;
        }
        cout << save << endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值