poj2299(线段树+离散化)

Ultra-QuickSort
Time Limit: 7000MS Memory Limit: 65536K
Total Submissions: 52276 Accepted: 19179

Description

In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence 
9 1 0 5 4 ,

Ultra-QuickSort produces the output 
0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9
1
0
5
4
3
1
2
3
0

Sample Output

6

0

这个题由于输入数据最大会到999,999,999,而输入数据只有500000个数,所以要离散化,然后就是求每个位置逆序数然后相加就可以了,最开始一直没看懂怎么弄,看了好多博客才弄明白。

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#define middle int mid=(l+r)/2
#define lson i*2,l,mid
#define rson i*2+1,mid+1,r
#define mem(a,b) memset((a),(b),sizeof(a))
using namespace std;
const int M= 500010;
long long tr[M<<2];
int n,rk[M];
long long ans;
struct node
{
    int con,id;
} s[M];
bool cmp(node a,node b)
{
    return a.con<b.con;
}
void modify(int i,int l, int r,int num)
{
    tr[i]++;
    if(l==r) return ;
    middle;
    if(num<=mid) modify(lson, num);
    else modify(rson, num);
}
long long query(int i,int l,int r,int L,int R)
{
    if(L==l&&R==r) return tr[i];
    int mid=(l+r)/2;
    if(R<=mid) return query(lson,L,R);
    else if(L>mid) return query(rson,L,R);
    else return query(lson,L,mid)+query(rson,mid+1,R);
}
int main()
{
    while(~scanf("%d",&n)&&n)
    {
        mem(s,0);
        mem(tr,0);
        mem(rk,0);
        for(int i=0; i<n; i++)
        {
            scanf("%d",&s[i].con);
            s[i].id=i;
        }
        sort(s,s+n,cmp);
        for(int i=0;i<n;i++)
            rk[s[i].id]=i+1;
        ans=0;
        for(int i=0;i<n;i++)
        {
            int x=rk[i];
            ans+=query(1,1,n+1,x+1,n+1);
            modify(1,1,n+1,x);
        }
        printf("%lld\n",ans);
    }
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值