POJ 1258 Agri-Net

Description

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course. 
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms. 
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm. 
The distance between any two farms will not exceed 100,000. 

Input

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

Output

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

Sample Input

4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0

Sample Output

28

题目大意:有n个农场,已知这n个农场都互相相通,
有一定的距离,现在每个农场需要装光纤,
问怎么安装光纤能将所有农场都连通起来,
并且要使光纤距离最小,输出安装光纤的总距离


最小生成树 kruskal 


#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <queue>
#include <vector>
#include <cmath>
#include <stack>
#include <string>
#include <map>
#include <set>
#define pi acos(-1)
#define LL long long
#define INF 0x3f3f3f3f
using namespace std;
typedef pair<int, int> P;
const int maxn = 1e5 + 5;

struct Way
{
	int u, v, w;
}way[maxn];
int cmp(Way a, Way b)
{
	if (a.w < b.w) return 1;
	return 0;
}
int ret[105];
int find(int a)
{
	if (ret[a] == -1) return a;
	return ret[a] = find(ret[a]);
}
int main(void)
{
//	freopen("C:\\Users\\wave\\Desktop\\NULL.exe\\NULL\\in.txt","r", stdin);
	int n, i, j, k, cnt, t, sum, u, v, w;
	while (cin >> n)
	{
		cnt = 0;
		for (i = 1; i <= n; i++){
			for (j = 1; j <= n; j++){
				scanf("%d", &t);
				if (j > i){
					way[++cnt].u = i;
					way[cnt].v = j;
					way[cnt].w = t;
				}
			}
		}
		sort(way+1, way+1+cnt, cmp);
		memset(ret, -1, sizeof(ret));
		sum = 0;
		for (i = 1; i <= cnt; i++){
			u = way[i].u;
			v = way[i].v;
			int x = find(u);
			int y = find(v);
			if (x == y) continue;
			ret[x] = y;
			sum += way[i].w;
		}
		cout << sum << endl;
	}
	
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值