HDU 1394 Minimum Inversion Number

Description

The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj. 

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following: 

a1, a2, ..., an-1, an (where m = 0 - the initial seqence) 
a2, a3, ..., an, a1 (where m = 1) 
a3, a4, ..., an, a1, a2 (where m = 2) 
... 
an, a1, a2, ..., an-1 (where m = n-1) 

You are asked to write a program to find the minimum inversion number out of the above sequences. 

Input

The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1. 

Output

For each case, output the minimum inversion number on a single line. 

Sample Input

10
1 3 6 9 0 8 5 7 4 2

Sample Output

16

题意:给定一个长度为n的数组,
每次可以把当前第一个元素放到最后面,直到数组循环一遍,
问这个过程中最少的逆序对数

用归并排序算法可以做 在这里用树状数组
因为输入的数为 0~(n-1) 而树状数组是从1开始的 所以对每个数先+1
然后构造一个值的范围为1~n的BIT(树状数组)
Sum(a[i])就表示 前i个数中小于等于a[i]的数 
因此当前序列下 在前i个数中 a[i]的逆序对数就为 i-Sum(a[i])  
然后都加上就是当前序列的全部逆序对数

然后每次把第一个数放到最后去 
每次逆序对数减少 n-a[i] 增加a[i]-1个 写写就知道了 

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <queue>
#include <vector>
#include <cmath>
#include <stack>
#include <string>
#include <map>
#include <set>
#define pi acos(-1)
#define LL long long
#define ULL unsigned long long
#define INF 0x3f3f3f3f
#define lson l,mid,rt<<1
#define rson mid+1,r,rt<<1|1
using namespace std;
typedef pair<int, int> P;
const int maxn = 5e3 + 5;

int C[maxn], n;
int a[maxn];
int lowbit(int x)
{	return x & (-x); }
void Update(int x, int k)
{
	while (x <= n){
		C[x] += k;
		x += lowbit(x);
	}
}
int Sum(int x)
{
	int res = 0;
	while (x){
		res += C[x];
		x -= lowbit(x);
	}
	return res;
}
int main(void)
{
//	freopen("C:\\Users\\wave\\Desktop\\NULL.exe\\NULL\\in.txt","r", stdin);
	int i, j, t, ans;
	while (cin >> n)
	{
		memset(C, 0, sizeof(C));
		ans = 0;
		for (i = 1; i <= n; i++){
			scanf("%d", &a[i]);
			a[i]++;
			Update(a[i], 1);
			ans += i - Sum(a[i]);
		}
		t = ans;
		for (i = 1; i < n; i++){
			t += (n - a[i]) - (a[i] - 1);
			ans = min(ans, t);
		}
		printf("%d\n", ans);
	}

	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值