POJ 2155 Matrix

Description

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N). 

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions. 

1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2). 
2. Q x y (1 <= x, y <= n) querys A[x, y]. 

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case. 

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2 y2", which has been described above. 

Output

For each querying output one line, which has an integer representing A[x, y]. 

There is a blank line between every two continuous test cases. 

Sample Input

1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1

Sample Output

1
0
0
1


给一个n*n矩阵 初始化值全为0。 然后有m个指示进行两个操作
操作1:给出子矩阵的左上角和右下角坐标,矩阵里的元素 1变0 ,0 变1

操作2:给出询问,问当前点(x,y)的值是多少。

这个写得好
http://blog.csdn.net/zxy_snow/article/details/6264135

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <queue>
#include <vector>
#include <cmath>
#include <stack>
#include <string>
#include <map>
#include <set>
#define pi acos(-1)
#define LL long long
#define ULL unsigned long long
#define INF 0x3f3f3f3f
#define lson l,mid,rt<<1
#define rson mid+1,r,rt<<1|1
using namespace std;
typedef pair<int, int> P;
const int maxn = 1e3 + 5;

int n, m;
int C[maxn<<2][maxn<<2];

int lowbit(int x)
{	return x & (-x); }
void update(int x, int y)
{
	int i, j;
	for (i = x; i <= n; i += lowbit(i))
		for (j = y; j <= n; j += lowbit(j))
			C[i][j]++;
}
int Getsum(int x, int y)
{
	int res = 0, i, j;
	for (i = x; i != 0; i -= lowbit(i))
		for (j = y; j != 0; j -= lowbit(j))
			res += C[i][j];
	return res;
}
int main(void)
{
//	freopen("C:\\Users\\wave\\Desktop\\NULL.exe\\NULL\\in.txt","r", stdin);
	int T, i, j, x1, y1, x2, y2;
	char s[2];
	scanf("%d", &T);
	while (T--)
	{
		memset(C, 0, sizeof(C));
		scanf("%d %d", &n, &m);	
		while(m--){
			scanf("%s", &s);
			if (s[0] == 'C'){
				scanf("%d %d %d %d", &x1, &y1, &x2, &y2);
				update(x1, y1);
				update(x1, y2+1);
				update(x2+1, y1);
				update(x2+1, y2+1);
			}
			else {
				scanf("%d %d", &x1, &y1);
				printf("%d\n", Getsum(x1, y1) % 2);
			}
		} 
		printf("\n");
	}	
	
	return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值