HDU 5773 The All-purpose Zero

Problem Description
?? gets an sequence S with n intergers(0 < n <= 100000,0<= S[i] <= 1000000).?? has a magic so that he can change 0 to any interger(He does not need to change all 0 to the same interger).?? wants you to help him to find out the length of the longest increasing (strictly) subsequence he can get.
 

Input
The first line contains an interger T,denoting the number of the test cases.(T <= 10)
For each case,the first line contains an interger n,which is the length of the array s.
The next line contains n intergers separated by a single space, denote each number in S.
 

Output
For each test case, output one line containing “Case #x: y”(without quotes), where x is the test case number(starting from 1) and y is the length of the longest increasing subsequence he can get.
 

Sample Input
  
  
2 7 2 0 2 1 2 0 5 6 1 2 3 3 0 0
 

Sample Output
  
  
Case #1: 5 Case #2: 5
Hint
In the first case,you can change the second 0 to 3.So the longest increasing subsequence is 0 1 2 3 5.
 

Author
FZU
 

Source
 

Recommend
wange2014



给一个数列 其中0可以替换成任意interger(包括负数),
在此基础上求最长递增子序列 

摘自  http://blog.csdn.net/l954688947/article/details/52057455
解题思路:无疑LIS,将所有的0全部提取出来,
求出此时序列的LIS(不含0的),这是针对0在子序列的外面的情况,
如0,1,2,3,0.那么如果0在子序列中间怎么办?
很简单,把读入的非0的数的值减去这个数前面0的个数即可,
如1,2,0,3,4。在提取出0后序列其实为1,2,2,3,
LIS的长度为3,加上0的个数则为答案。

好像有点道理。。。。

 

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <queue>
#include <vector>
#include <cmath>
#include <stack>
#include <string>
#include <map>
#include <set>
#define pi acos(-1)
#define LL long long
#define ULL unsigned long long
#define inf 0x3f3f3f3f
#define INF 1e18
#define lson l,mid,rt<<1
#define rson mid+1,r,rt<<1|1
using namespace std;
typedef pair<int, int> P;
const int maxn = 1e5 + 5;

int a[maxn];
int seq[maxn], len[maxn];
int main(void)
{
//	freopen("C:\\Users\\wave\\Desktop\\NULL.exe\\NULL\\in.txt","r", stdin);
    int T, cas = 1, n, i, j, cnt, t, k, lmax;
    scanf("%d", &T);
    while (T--)
    {
        scanf("%d", &n);
        t = cnt = 0;
        for (i = 1; i <= n; i++){
            scanf("%d", &k);
            if (!k) cnt++;
            else a[++t] = k - cnt;
        }
        if (!t){
            printf("Case #%d: %d\n", cas++, n);
            continue;
        }
        seq[1] = a[1];
        len[1] = 1;
        lmax = 1;
        for (i = 2; i <= t; i++){
            if (a[i] > seq[lmax])
                seq[++lmax] = a[i];
            else {
                int pos = lower_bound(seq+1, seq+lmax, a[i]) - seq;
                seq[pos] = a[i];
            }
        }
        printf("Case #%d: %d\n", cas++, lmax+cnt);
    }

	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值