POJ Beauty Contest (凸包)

Description

Bessie, Farmer John's prize cow, has just won first place in a bovine beauty contest, earning the title 'Miss Cow World'. As a result, Bessie will make a tour of N (2 <= N <= 50,000) farms around the world in order to spread goodwill between farmers and their cows. For simplicity, the world will be represented as a two-dimensional plane, where each farm is located at a pair of integer coordinates (x,y), each having a value in the range -10,000 ... 10,000. No two farms share the same pair of coordinates. 

Even though Bessie travels directly in a straight line between pairs of farms, the distance between some farms can be quite large, so she wants to bring a suitcase full of hay with her so she has enough food to eat on each leg of her journey. Since Bessie refills her suitcase at every farm she visits, she wants to determine the maximum possible distance she might need to travel so she knows the size of suitcase she must bring.Help Bessie by computing the maximum distance among all pairs of farms. 

Input

* Line 1: A single integer, N 

* Lines 2..N+1: Two space-separated integers x and y specifying coordinate of each farm 

Output

* Line 1: A single integer that is the squared distance between the pair of farms that are farthest apart from each other. 

Sample Input

4
0 0
0 1
1 1
1 0

Sample Output

2

Hint

Farm 1 (0, 0) and farm 3 (1, 1) have the longest distance (square root of 2) 

凸包求直径
采用Graham+Rotating_Calipers,Graham复杂度nlogn
参考:http://www.cnblogs.com/Booble/archive/2011/04/03/2004865.html

http://blog.csdn.net/niuox/article/details/10500005


#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <queue>
#include <vector>
#include <cmath>
#include <stack>
#include <string>
#include <map>
#include <set>
#define pi acos(-1)
#define LL long long
#define ULL unsigned long long
#define inf 0x3f3f3f3f
#define INF 1e18
#define lson l,mid,rt<<1
#define rson mid+1,r,rt<<1|1
#define mem0(a) memset(a, 0, sizeof(a))
#define memi(a) memset(a, inf, sizeof(a))
#define mem1(a) memset(a, -1, sizeof(a))
using namespace std;
typedef pair<int, int> P;
const double eps = 1e-10;
const int maxn = 1e5 + 5;
const int mod = 1e8;

struct Point{
	int x, y;
	Point(){ }
	Point(int x, int y):x(x), y(y){ }
    Point operator - (const Point& p) const {
        return Point(x - p.x, y - p.y);
    }
    int operator * (const Point& p) const { // 点乘 
        return x * p.x + y * p.y;
    }
    int operator ^ (const Point& p) const { // 叉乘 
        return x * p.y - y * p.x;
    }
    bool operator < (const Point& p) const {
        return (x == p.x && y < p.y) || x < p.x;
    }
};
int convex_hull(Point* p, Point* vex_p, int n)
{
    sort(p, p + n);
    int k = 0;
    for (int i = 0; i < n; i++){ // 构造下侧的链
        while (k > 1 && ((vex_p[k-1] - vex_p[k-2]) ^ (p[i] - vex_p[k-1])) <= 0) k--;
        vex_p[k++] = p[i];
    }
    int t = k;
    for (int i = n-2; i >= 0; i--){	// 构造上测的链
        while (k > t && ((vex_p[k-1] - vex_p[k-2]) ^ (p[i] - vex_p[k-1])) <= 0) k--;
        vex_p[k++] = p[i];
    }
    return k-1; // 第一个点会重复两次 所以要减 1
}
int cal_dis(Point a, Point b){
    int x = a.x - b.x;
    int y = a.y - b.y;
    return x*x + y*y;
}
void RotatingCalipers(Point* vex_p, int m) // 旋转卡壳 
{
    if (m == 2){ // 特别处理凸包退化的情况
        printf("%d\n", cal_dis(vex_p[0], vex_p[1]));
        return;
    }
    int i = 0, j = 0;  // 某个方向上的踵点对
    for (int k = 0; k < m; k++){
        if (!(vex_p[i] < vex_p[k])) i = k; // 最小的点 
        if (vex_p[j] < vex_p[k]) j = k; // 最大的点 
    }
    int res = 0;
    int si = i, sj = j; 
    while(i != sj || j != si){ // 将平行线逐步旋转   其实就是两条平行线绕着凸包转了一圈 
        res = max(res, cal_dis(vex_p[i], vex_p[j]));
        // 判断先转到边i-(i+1) 还是边j-(j+1) 
        // 不过用叉乘的正负来判断先到哪条边 不太懂 
        if (((vex_p[(i+1) % m] - vex_p[i]) ^ (vex_p[(j+1) % m] - vex_p[j])) < 0)
            i = (i + 1) % m; // 先转到边i-(i+1)
        else
			j = (j + 1) % m; //先转到边j-(j+1)
	}
    printf("%d\n", res);
}
int n;
Point p[maxn], vex_p[maxn];
int main(void)
{
//	freopen("C:\\Users\\wave\\Desktop\\NULL.exe\\NULL\\in.txt","r", stdin);
    while (~scanf("%d", &n))
    {
        for (int i = 0; i < n; i++)
            scanf("%d %d", &p[i].x, &p[i].y);
        int m = convex_hull(p, vex_p, n);
		RotatingCalipers(vex_p, m);
    }

	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值