P1691 有重复元素的排列问题 (模拟全排列)

题目描述

设R={r1,r2,……,rn}是要进行排列的n个元素。其中元素r1,r2,……,rn可能相同。使设计一个算法,列出R的所有不同排列。

给定n以及待排列的n个元素。计算出这n个元素的所有不同排列。

输入输出格式

输入格式:

 

第1行:元素个数n(1<=n<500)

第2行:一行字符串,待排列的n个元素

 

输出格式:

 

计算出的n个元素的所有不同排列,最后一行是排列总数。

 

输入输出样例

输入样例#1: 复制

4
aacc

输出样例#1: 复制

aacc
acac
acca
caac
caca
ccaa
6

说明

输出按字典顺序排


如果按字母挨个搜索,45分,直接T,舒服. 然后直接用next 直接过,你就在想,为啥next能过,因为next是按字母出现的次数搜索的啊! 记得用数组记录出现的次数来循环,不要用map! map会很慢!因为ma是树


//神兽勿删

// ━━━━━━神兽出没━━━━━━
//    ┏┓     ┏┓
//   ┏┛┻━━┛┻┓
//   ┃       ┃
//   ┃ ━     ┃
//   ┃┳┛┗┳    ┃
//   ┃       ┃
//   ┃ ┻     ┃
//   ┃       ┃
//   ┗━┓   ┏┛ Code is far away from bug with the animal protecting
//      ┃   ┃    神兽保佑,代码无bug
//       ┃   ┃
//       ┃   ┗━━━┓
//         ┃        ┣┓
//      ┃        ┏┛
//     ┗┓┓┏━┳┓┏┛
//       ┃┫┫  ┃┫┫
//       ┗┻┛  ┗┻┛
//
// ━━━━━━感觉萌萌哒━━━━━━
//          ┏┓  ┏┓
//        ┏┛┻━━┛┻┓
//        ┃      ┃  
//        ┃   ━  ┃
//        ┃ >  < ┃
//        ┃      ┃
//        ┃... ⌒ ...  ┃
//        ┃      ┃
//        ┗━┓   ┏┛
//           ┃   ┃ Code is far away from bug with the animal protecting          
//           ┃   ┃   神兽保佑,代码无bug
//           ┃   ┃           
//           ┃   ┃        
//           ┃   ┃
//           ┃   ┃           
//           ┃   ┗━━━┓
//           ┃       ┣┓
//           ┃       ┏┛
//           ┗┓┓┏━┳┓┏┛
//            ┃┫┫ ┃┫┫
//            ┗┻┛ ┗┻┛
#include<bits/stdc++.h>
//#include <iostream>
//#pragma GCC optimize(2)
using namespace std;
#define maxn 505
#define inf 1e18
typedef long long ll;
const ll mod = 1e9+7;
ll n,ans,arr[maxn];
char str[maxn],temp[maxn];
void dfs(ll num,ll k)
{
    if(num == n)
    {
        ans++;

        for(ll i = 0; i < n; i++)
            cout << temp[i];

        cout << endl;

    }
    else
    {
        for(ll i = 0; i < 26; i++)
        {
            if(arr[i]!=0)
            {

                temp[k] = 'a' + i;
                arr[i]--;
                dfs(num+1,k+1);
                arr[i]++;

            }
        }
    }
    return ;
}
int main()
{
    ios::sync_with_stdio(false);
    cin.tie(0);cout.tie(0);

    cin >> n;
    cin >> str;

    for(ll i = 0; i < n; i++)
        arr[ str[i]-'a' ] ++;

    dfs(0,0);

    cout << ans << endl;

    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值