STL初步:大理石在哪儿?

uva 10474

现有N个大理石,每个大理石上写了一个非负整数。首先把各数从小到大排序,然后回答Q个问题。每个问题问是否有一个大理石写着某个整数x,如果是,还要回答哪个大理石上写着x。排序后的大理石从左到右编号为1~N。(样例中,为了节约篇幅,所有大理石上的数合并到一行,所有问题也合并到一行。)
样例输入:
4 1 
2 3 5 1
5
5 2
1 3 3 3 1
  2 3 
样例输出:
CASE# 1:
5 found at 4
CASE# 2:
2 not found
3 found at 3
提示:sort函数与lower_bound函数结合完成
注:codeblocks测试数据通过
#include<iostream>
#include<algorithm>
using namespace std;
const int maxn=10000;
int main()
{
    int n,m,a[maxn],b[maxn],cases=1;
    while(cin>>n>>m)
    {
        for(int i=1;i<=n;i++)
            cin>>a[i];
        for(int i=1;i<=m;i++)
            cin>>b[i];
        cout<<"CASE# "<<cases<<":"<<endl;
        cases++;
        sort(a+1,a+n+1);
        for(int i=1;i<=m;i++)
        {
            int p=lower_bound(a+1,a+n+1,b[i])-a;//注意·此处
            if(a[p]==b[i])
                cout<<b[i]<<" found at "<<p<<endl;
            else
                cout<<b[i]<<" not found"<<endl;
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值