POJ1050 TO THE MAX

Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle. 
As an example, the maximal sub-rectangle of the array: 

0 -2 -7 0 
9 2 -6 2 
-4 1 -4 1 
-1 8 0 -2 
is in the lower left corner: 

9 2 
-4 1 
-1 8 
and has a sum of 15. 

Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4
0 -2 -7 0 9 2 -6 2
-4 1 -4  1 -1

8  0 -2

Sample Output

15

Source






DP水题
但是想一个好方法来穷举所有子矩阵不容易。
借鉴代码:
#include <iostream>  
#include <algorithm> 
using namespace std;
int a[102][102]={{0}};
int maxs=0,n;
bool dp(int numbs,int row)
{
int thisnum=0,thismax=0;
for(int j=1;j<=n;j++)
{
thisnum+=(a[row+numbs-1][j]-a[row-1][j]);
if(thisnum>thismax)
thismax=thisnum;
if(thisnum<0)
thisnum=0;
}
if(maxs<thismax)
maxs=thismax;
return 1;
}


int main()
{
// freopen("in.txt","r",stdin);
while(cin>>n)
{
int temp;
maxs=0;
for(int i=1;i<=n;i++)
{
for(int j=1;j<=n;j++)
{
cin>>temp;
a[i][j]=a[i-1][j]+temp;
}
}
for(int i=1;i<=n;i++)
{
for(int j=1;j<=n-i+1;j++)
{
dp(i,j);
}
}
cout<<maxs<<endl;
}
return 0;
}

重点在于:1.输入时,每个数都是上一列与这一列的数之和,这样以相减的方式可以轻松得到所有单个数和几行的数的和。
2.在列之间的计算时,当几列的加和小于0时,将数记为0。当数小于0,则继续相加必然得到比后面的数更小的数。
这个代码真是聪明=。=,技不如人甘拜下风。
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值