7-3 两个有序链表序列的交集

该程序实现了一个功能,即给定两个非降序链表序列S1和S2,通过创建一个新的链表S3来表示它们的交集。程序首先读取两个输入序列,然后使用ListInsert函数将元素插入链表。Merge函数比较两个链表的元素,如果找到相同的元素,则将其插入结果链表。最后,输出交集链表的内容。如果链表为空,则输出'NULL'。
摘要由CSDN通过智能技术生成

已知两个非降序链表序列S1与S2,设计函数构造出S1与S2的交集新链表S3。

输入格式:

输入分两行,分别在每行给出由若干个正整数构成的非降序序列,用−1表示序列的结尾(−1不属于这个序列)。数字用空格间隔。

输出格式:

在一行中输出两个输入序列的交集序列,数字间用空格分开,结尾不能有多余空格;若新链表为空,输出NULL

输入样例:

1 2 5 -1
2 4 5 8 10 -1

输出样例:

2 5
#include <stdio.h>
#include <malloc.h>
typedef int Elemtype;
typedef int Status;
#define OK 1
#define ERROR 0
typedef struct Link_list
{
    Elemtype date;
    struct  Link_list *next;

} *SqList;
SqList InitList()
{
    SqList L;
    L=(SqList)malloc(sizeof(struct Link_list));
    L->next = NULL;
    return L;

}
void ListInsert(SqList L,Elemtype e)
{
    SqList next=(SqList)malloc(sizeof(struct Link_list));
    next->date = e;
    L->next = next;
    next->next=NULL;
}
void print(SqList L)
{  int f = 0;
    L = L->next;
    while(L!=NULL)
    {
        if(f == 0)
       {
           printf("%d",L->date);
           f=1;
       }
       else printf(" %d",L->date);
        L = L->next;
    }


}
SqList Merge(SqList A,SqList B,SqList C)
{
    A = A->next;
    B = B->next;
    SqList c = C;
    while(A!=NULL&&B!=NULL)
    {
         if(A->date < B->date)
         {
             A = A ->next;


         }
         else if(A->date == B->date)
         {

             ListInsert(C,A->date);
               C = C->next;
              A = A ->next;
               B = B ->next;
         }
         else{
              B = B ->next;
         }

    }

return c;

}
int main()
{
    SqList A = InitList();
    SqList B= InitList();
    SqList C= InitList();
    SqList a = A;
    SqList b = B;
    while(1)
    {
        int e;
        scanf("%d",&e);
        if(e==-1)
            break;
        ListInsert(A,e);
        A =  A->next;
    }

    while(1)
    {
        int e;
        scanf("%d",&e);
        if(e==-1)
            break;
        ListInsert(B,e);
        B =  B->next;
    }
C = Merge(a,b,C);
if(C->next!=NULL)
print(C);
else printf("NULL");

}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值