BAPC 2014 Preliminary 暑假第一场F: Runway Planning

题目链接
Most airports have multiple runways. To identify runways, they are given a number indicating
the direction of the runway. Such a runway number is obtained by dividing the heading
of the runway in degrees by ten, rounding the result, and optionally prefixing it with a ‘0’ if
the result has only a single digit. For example, a runway with a heading of 82◦
is indicated by
the number 08.
If you are paying attention, you might think “a runway can be used in both directions,
and therefore has two headings, but it is only assigned one runway number.” You are correct:
normally a runway is identified by two numbers, based on the direction in which the runway
is used. To simplify matters, we only concern ourselves with the smallest of these two numbers,
except if it is zero; we then use 18 instead. The runway numbers thus range from 01 to
18.
Now, you might think, “what if two runways have the same heading?” In that case, the
characters ‘L’ and ‘R’ are appended to the number of the left and right runway, respectively.
But what if three runways have the same heading? Then, the character ‘C’ is appended to the
center runway. “But”, I can hear you ask, “what if four runways have the same heading?”
If you really want to know, look up how Dallas/Fort Worth International Airport solved this
problem after the contest. At any rate, we do not concern ourselves with multiple runways
having the same heading in this problem, so you can forget all you read in this paragraph.
The runway in use is mostly determined by the current direction of the wind. It is preferred
to take off and land with headwind. If it is not possible to have the wind coming from
straight ahead, its direction should be as close to that as possible. For example, if an airport
has the runways 05 and 15, and the wind has a heading of 70◦
, taking off and landing using
runway 05 is preferred, since the heading of that runway is closest to the heading of the wind.
Now, consider an airport already having one or more runways, and planning the construction
of a new runway. Obviously, this runway should have a unique runway number:
not only would we otherwise have a problem outside the boundaries of our restricted runway
numbering outlined above, but, most importantly, this increases the probability of being able
to take off or land with headwind.
The engineers at the airport under consideration have already determined the heading of
the new runway, but still need you to determine the runway number. Note that the engineers
are not very considerate with their input to your problem. They give you one heading of the
runway, but it can be either the lowest or the highest heading of the runway. Be sure to give
the lowest of the two runway numbers, as discussed in the second paragraph of this problem
statement, even if you are given the highest of the two headings from the engineers.
Input
On the first line one positive number: the number of test cases, at most 100. After that per test
case:
• one line with a single integer h (1 ≤ h ≤ 360): the heading of the new runway in degrees.
Output
Per test case:
• one line with the runway number of the newly constructed runway.
14 Problem F: Runway Planning
Sample in- and output
样例输入
4
82
115
316
4
样例输出
08
12
14
18

题意:啥,看半天在说什么,不管,你就讲数除以10,四舍五入就行了,如果大于185度的先减去180,然后再除以10四舍五入,如果最后结果是0就输出18,(这样就只要大于180度的就减去180度结果是一样的) 所以水题

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<algorithm>
int T;
using namespace std;
int main(){
    cin>>T;
    int h;
while(T--){
    cin>>h;
    if(h>=185){
        h=h-180;
    }
    int a=h%10;
    h=h/10;
    if(a>=5){
        h+=1;
    }
    if(h==0){
        h=18;
    }
    if(h<10){
        cout<<"0"<<h<<endl;
    }
    else
    cout<<h<<endl;
}
return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值