Coins POJ - 1742

Coins
Time Limit: 3000MS Memory Limit: 30000K
Total Submissions: 41207 Accepted: 13956

Description

People in Silverland use coins.They have coins of value A1,A2,A3...An Silverland dollar.One day Tony opened his money-box and found there were some coins.He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch. 
You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins. 

Input

The input contains several test cases. The first line of each test case contains two integers n(1<=n<=100),m(m<=100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1<=Ai<=100000,1<=Ci<=1000). The last test case is followed by two zeros.

Output

For each test case output the answer on a single line.

Sample Input

3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0

Sample Output

8
4

Source

LouTiancheng@POJ


题意:

先输入输入每种硬币的价值,再输入每种硬币的个数

求在m以内能组成几种价值


题解:多重背包问题,可以参考《挑战程序设计竞赛》P63

ac代码:

//

//  main.cpp

//  Coins POJ - 1742

//

//  Created by Apple on 2018/3/23.

//  Copyright © 2018 Apple. All rights reserved.

//


#include <iostream>

#include<cstring>

#include<algorithm>

using namespace std;

const int maxn = 100010;

int a[100010];

int b[100010];

int dp[maxn];

int n,m;


void solve()

{

    memset(dp,-1,sizeof(dp));

    dp[0]=0;

    for(int i=0;i<n;i++)

    {

        for(int j=0;j<=m;j++)

        {

            if(dp[j]>=0)

                dp[j]=b[i];

            else if(j<a[i]||dp[j-a[i]]<=0)

                dp[j]=-1;

            else

                dp[j]=dp[j-a[i]]-1;

            

        }

    }

    int ans = 0;

    for(int i = 1; i <= m; i++)

        if(dp[i]>=0) ans++;

    printf("%d\n", ans);

}


int main()

{

    while(scanf("%d%d",&n,&m)!=EOF)

    {

        if(n==0&&m==0)

            break;

        for(int i=0;i<n;i++)

            scanf("%d",&a[i]);

        for(int i=0;i<n;i++)

            scanf("%d",&b[i]);

        solve();

        

        

        

    }

}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值