HDU6201 | 2017 ACM-ICPC 亚洲区(沈阳赛区)网络赛-H transaction transaction transaction

3 篇文章 0 订阅
1 篇文章 0 订阅

transaction transaction transaction

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 132768/132768 K (Java/Others)
Total Submission(s): 98    Accepted Submission(s): 42


Problem Description
Kelukin is a businessman. Every day, he travels around cities to do some business. On August 17th, in memory of a great man, citizens will read a book named "the Man Who Changed China". Of course, Kelukin wouldn't miss this chance to make money, but he doesn't have this book. So he has to choose two city to buy and sell. 
As we know, the price of this book was different in each city. It is  ai   yuan  in  i t  city. Kelukin will take taxi, whose price is  1 yuan  per km and this fare cannot be ignored.
There are  n1  roads connecting  n  cities. Kelukin can choose any city to start his travel. He want to know the maximum money he can get.
 

Input
The first line contains an integer  T  ( 1T10 ) , the number of test cases. 
For each test case:
first line contains an integer  n  ( 2n100000 ) means the number of cities;
second line contains  n  numbers, the  i th  number means the prices in  i th  city;  (1Price10000)  
then follows  n1  lines, each contains three numbers  x y  and  z  which means there exists a road between  x  and  y , the distance is  z km   (1z1000)
 

Output
For each test case, output a single number in a line: the maximum money he can get.
 

Sample Input
  
  
1 4 10 40 15 30 1 2 30 1 3 2 3 4 10
 

Sample Output
  
  
8
 

Source
 


     这题第一反应就是用spfa,可是比赛的时候就想着跑N次,然后再嵌套循环去求最大收入,但是明显会TLE.....
比赛后看别人的才发现可以直接跑N次spfa,然后最大收入重新写一个循环,因为最大值是会被不断替换的,不管根节点是谁,最大值都是确定的。
本来以为这样就对了,后面又发现树形dp更方便解决。很厉害。


    费用流AC代码
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <algorithm>
using namespace std;

const int MaxN = 200000;
int n, m, all;
int pre[MaxN + 5], last[MaxN + 5], other[MaxN + 5], cost[MaxN + 5];
int    dis[MaxN + 5], seq[MaxN + 5],w[MaxN + 5];
bool Inque[MaxN + 5];


void Build(int x, int y, int w)
{
	pre[++all] = last[x];
	last[x] = all;
	other[all] = y;
	cost[all] = w;
}

void Bfs(int s)
{
	int head = 1, tail = 1, now, ed, dr;
	seq[tail] = s;
	Inque[s] = 1;
	while(head <= tail)
	{
		now = seq[head];
		ed = last[now];
		while(ed != -1)
		{
			dr = other[ed];
			if(dis[now] - w[now] - cost[ed] + w[dr] > dis[dr])
			{
				dis[dr] = dis[now] - cost[ed] - w[now] + w[dr];
				if(!Inque[dr])
				{
					Inque[dr] = 1;
					seq[++tail] = dr;
				}
			}
			ed = pre[ed];
		}
		Inque[now] = 0;
		head++;
	}
}

int main()
{
	int t;
	scanf("%d",&t);
	while (t--)
	{
		all = -1;
		memset(last, -1, sizeof(last));
		memset(w,0,sizeof(w));
		memset(dis,0,sizeof(dis));
		scanf("%d", &n);
		for (int i = 1; i <= n; i++)
			scanf("%d",&w[i]);
		for(int i = 1; i <= n-1; i++)
		{
			int a, b, w;
			scanf("%d%d%d", &a, &b, &w);
			Build(a, b, w); Build(b, a, w);
		}
		memset(seq, 0, sizeof(seq));
		memset(Inque, 0, sizeof(Inque));
		int Max = 0;
		for (int i = 1; i <= n; i++)
		{
			Bfs(i);
		}
		for (int i = 1; i <= n; i++)
		{
			Max = max(Max,dis[i]);
		}
		printf("%d\n",Max);
	}
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值