POJ 3744 Scout YYF I

Description

YYF is a couragous scout. Now he is on a dangerous mission which is to penetrate into the enemy's base. After overcoming a series difficulties, YYF is now at the start of enemy's famous "mine road". This is a very long road, on which there are numbers of mines. At first, YYF is at step one. For each step after that, YYF will walk one step with a probability of p, or jump two step with a probality of 1- p. Here is the task, given the place of each mine, please calculate the probality that YYF can go through the "mine road" safely.

Input

The input contains many test cases ended with EOF.
Each test case contains two lines.
The First line of each test case is N (1 ≤ N ≤ 10) and p (0.25 ≤ p ≤ 0.75) seperated by a single blank, standing for the number of mines and the probability to walk one step.
The Second line of each test case is N integer standing for the place of N mines. Each integer is in the range of [1, 100000000].

Output

For each test case, output the probabilty in a single line with the precision to 7 digits after the decimal point.

Sample Input

1 0.5
2
2 0.5
2 4

Sample Output

0.5000000
0.2500000
 
  
解题思路:递推+矩阵快速幂优化。首先我们很容易得到走到第i个点的概率,dp[i] = dp[i-2]*(1-p) + dp[i-1] * p,由于数据范围很大所以想到利用矩阵来优化,又因为踩到每个地雷时代表死亡概率变为0,因此我们分段处理一下便可。
#include <ctime>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <string>
#include <vector>
#include <algorithm>
using namespace std;

struct Matrix {

    double mat[2][2];

    void init() {
        for(int i = 0; i < 2; ++i) {
            for(int j = 0; j < 2; ++j) {
                mat[i][j] = 0.0;
            }
        }
        //memset(mat, 0, sizeof(mat));
    }

    void unit() {
        //memset(mat, 0, sizeof(mat));
        mat[0][1] = mat[1][0] = 0.0;
        mat[0][0] = mat[1][1] = 1.0;
    }

    friend Matrix operator * (const Matrix &a, const Matrix &b) {
        Matrix c;
        c.init();
        for(int i = 0; i < 2; ++i) {
            for(int j = 0; j < 2; ++j) {
                for(int k = 0; k < 2; ++k) {
                    c.mat[i][j] += a.mat[i][k] * b.mat[k][j];
                }
            }
        }
        return c;
    }

    friend Matrix operator ^ (Matrix a, int x) {
        Matrix c; c.unit();
        while(x) {
            if(x&1) c = c * a;
            a = a * a;
            x >>= 1;
        }
        return c;
    }
};

int pos[20];

int main() {

    int N;
    double p;
    while(scanf("%d %lf", &N, &p) != EOF) {
        for(int i = 1; i <= N; ++i) {
            scanf("%d", &pos[i]);
        }
        sort(pos + 1, pos + N + 1);
        if(pos[1] == 1) {
            printf("%.7lf\n", 0.0);
            continue;
        }
        double p0 = 0, p1 = 1.0;
        Matrix a;
        a.mat[0][0] = 0;   a.mat[0][1] = 1 - p;
        a.mat[1][0] = 1.0; a.mat[1][1] = p;
        int id = 1;
        int curp = 1;
        while(id <= N) {
            a = a ^ (pos[id] - curp);
            p0 = p0 * a.mat[0][0] + p1 * a.mat[1][0];
            p1 = 0.0;
            p1 = p0 * (1-p);
            p0 = 0.0;
            curp = pos[id] + 1;
            id++;
            a.mat[0][0] = 0; a.mat[0][1] = 1 - p;
            a.mat[1][0] = 1; a.mat[1][1] = p;
        }
        printf("%.7lf\n", p1);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值