PAT甲级1002解题报告及疑惑

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:
K   N 1   a N 1   N 2   a N 2   . . .   N K   a N K K \ N_1 \ a_{N_1} \ N_2 \ a_{N_2} \ ... \ N_K \ a_{N_K} K N1 aN1 N2 aN2 ... NK aNK

where K K K is the number of nonzero terms in the polynomial, N i N_i Ni​​ and a N ​ i ( i = 1 , 2 , ⋯ , K ) a_{N_​i}(i=1,2,⋯,K) aNi(i=1,2,,K) are the exponents and coefficients, respectively. It is given that 1 ≤ K ≤ 10 , 0 ≤ N K < ⋯ < N 2 < N 1 ≤ 1000 1≤K≤10, 0≤N_K<⋯<N_2<N_1≤1000 1K10,0NK<<N2<N11000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2

My Code

#include <iostream>
using namespace std;

void do_union(double exponents_all[]);

int main()
{
	int n, exponents;
	double coefficients;
	double exponents_all[1001] = { 0 };
	//int output_all[10];

	for (int i = 0; i < 2; i++) 
	{
		cin >> n;
		while (n != 0)
		{
			cin >> exponents >> coefficients;
			exponents_all[exponents] += coefficients;
			n--;
		}
	}
	do_union(exponents_all);
}

void do_union(double exponents_all[])
{
	int count = 0;
	for (int i = 1000; i >= 0; i--)
	{
		if (exponents_all[i] != 0)
			count++;
	}
	cout << count;
	for (int j = 1000; j >= 0; j--)
	{
		if (exponents_all[j] != 0)
			printf(" %d %.1f", j, exponents_all[j]);
	}
}

疑惑

  • 我的代码提交之后,有一个样例没有通过,扣了两分,我感到非常疑惑。
    • 由于陈越姥姥并没有公布测试样例是什么,根据我的经验,可能是存在输入的系数为0的情况。
    • 根据题目,他并没有限制系数为0的情况,然而为了方法更简洁,我在void do_union(double exponents_all[])里的for循环将系数为0的情况跳过了。
    • 暂时没想到更简洁的方法,错了就错了吧。如果有朋友看出来问题,请斧正
  • 上述问题已经解决
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 3
    评论
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值