vuecli4 vue.3.0 IE 360浏览器兼容问题配置

首先·不需要安装第三方的转换es5的插件因为它已经内置

不多说废话-配置如下

package.json文件下的 browserslist对象

"browserslist": [
    "> 1%",
    "last 2 versions",
    "IE 11",
    "IE 10",
    "IE 9"
  ]

babel.config 文件下

module.exports = {
  presets: [
    '@vue/cli-plugin-babel/preset',
    [
      '@babel/preset-env',
      {
        useBuiltIns: 'entry'
      }
    ]
  ]
}

 

vue.config.js

module.exports = {

transpileDependencies: ['sockjs-client', 'js-base64', 'js-cookie'], // 是否引用第三方 es6+ 的插件进行ie兼容
 
}

在IE浏览器中运行

果不其然,报错

这个时候不要慌,先点开错误看一下

找到错误的最后一行,我们可以看到错误的依赖包

这个时候需要

显式的将这个依赖包放到vue.config.js中的transpileDependencies中去,告诉babel需要转换这个包

再次运行

还是有错,继续点开继续看

发现还有没有转换的包

继续上述步骤

以此类推,直到所有不能转换的包都显式转换

ok大功告成

已标记关键词 清除标记
相关推荐
©️2020 CSDN 皮肤主题: 游动-白 设计师:白松林 返回首页