1044 火星数字

火星人是以 13 进制计数的:

  • 地球人的 0 被火星人称为 tret。
  • 地球人数字 1 到 12 的火星文分别为:jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec。
  • 火星人将进位以后的 12 个高位数字分别称为:tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou。

例如地球人的数字 29 翻译成火星文就是 hel mar;而火星文 elo nov 对应地球数字 115。为了方便交流,请你编写程序实现地球和火星数字之间的互译。

输入格式:

输入第一行给出一个正整数 N(<100),随后 N 行,每行给出一个 [0, 169) 区间内的数字 —— 或者是地球文,或者是火星文。

输出格式:

对应输入的每一行,在一行中输出翻译后的另一种语言的数字。

输入样例:

4
29
5
elo nov
tam

输出样例:

hel mar
may
115
13

 测试点3,4一直过不了,希望大神指点

#include<bits/stdc++.h>
using namespace std;
int num;
string a[]={"tret","jan", "feb", "mar", "apr", "may", "jun", "jly", "aug", "sep", "oct", "nov", "dec"};
string b[]={"","tam", "hel", "maa", "huh", "tou", "kes", "hei", "elo", "syy", "lok", "mer", "jou"};
map<string,int>mp;
map<string,int>mv;
int main(void)
{
	mp["tret"]=0,mp["jan"]=1,mp["feb"]=2,mp["mar"]=3,mp["apr"]=4,mp["may"]=5,mp["jun"]=6;
	mp["jly"]=7,mp["aug"]=8,mp["sep"]=9,mp["oct"]=10,mp["nov"]=11,mp["dec"]=12;
	mv["tam"]=1,mv["hel"]=2,mv["maa"]=3,mv["huh"]=4,mv["tou"]=5,mv["kes"]=6;
	mv["kes"]=7,mv["elo"]=8,mv["syy"]=9,mv["lok"]=10,mv["mer"]=11,mv["jou"]=12;
	int n;cin>>n;
	string s;getline(cin,s);
	for(int i=0;i<n;i++)
	{
		getline(cin,s);
		if(s[0]>='0'&&s[0]<='9')
		{
			int t=stoi(s);
			if(t<13) cout<<a[t]<<endl;
			else if(t%13==0) cout<<b[t/13]<<endl;
			else cout<<b[t/13]<<" "<<a[t%13]<<endl;
		}
		else
		{
			if(s.size()>3)
			{
				string a=s.substr(0,3);string b=s.substr(4,3);
				cout<<(mv[a]*13+mp[b])<<endl;
			}
			else
			{
				if(mv[s]) cout<<mv[s]*13<<endl;
				else if(mp[s]) cout<<mp[s]<<endl;
			}
		}
	}
	return 0;
}
#include<bits/stdc++.h>
using namespace std;
int num;
string a[]={"tret","jan", "feb", "mar", "apr", "may", "jun", "jly", "aug", "sep", "oct", "nov", "dec"};
string b[]={"","tam", "hel", "maa", "huh", "tou", "kes", "hei", "elo", "syy", "lok", "mer", "jou"};
int main(void)
{
	cin>>num;
	string s;getline(cin,s);
	for(int i=0;i<num;i++)
	{
		getline(cin,s);
		if(s[0]>='0'&&s[0]<='9')
		{
			int temp=stoi(s);
			if(temp<=12) cout<<a[temp]<<endl;
			else if(temp%13==0) cout<<b[temp/13]<<endl;
			else cout<<b[temp/13]<<" "<<a[temp%13]<<endl;
		}
		else
		{
			vector<string> vc;
			stringstream l(s);
			string x;
			int res=0;
			while(l>>x) vc.push_back(x);
			if(vc.size()==1)
			{
				for(int i=0;i<=12;i++) if(vc[0]==a[i]) res=i;
				for(int i=0;i<=12;i++) if(vc[0]==b[i]) res=i*13;
			}
			else
			{
				for(int i=1;i<=12;i++) if(vc[0]==b[i]) res=i*13;
				for(int i=0;i<=12;i++) if(vc[1]==a[i]) res+=i;
			}
			cout<<res<<endl;
		}
	}
	return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值