ZOJ-1937 Addition Chains

An addition chain for n is an integer sequence <a0, a1,a2,...,am> with the following four properties:

  • a0 = 1
  • am = n
  • a0 < a1 < a2 < ... < am-1 < am
  • For each k (1 <= k <= m) there exist two (not necessarily different) integers i and j (0 <= i, j <= k-1) with ak = ai + aj

You are given an integer n. Your job is to construct an addition chain for n with minimal length. If there is more than one such sequence, any one is acceptable.

For example, <1, 2, 3, 5> and <1, 2, 4, 5> are both valid solutions when you are asked for an addition chain for 5.


Input

The input will contain one or more test cases. Each test case consists of one line containing one integer n (1 <= n <= 100). Input is terminated by a value of zero (0) for n.


Output

For each test case, print one line containing the required integer sequence. Separate the numbers by one blank. 
 

Sample Input

5
7
12
15
77
0


Sample Output

1 2 4 5
1 2 4 6 7
1 2 4 8 12
1 2 4 5 10 15
1 2 4 8 9 17 34 68 77

题目大意:a[0]=1,a[m]=n,a[0]<a[1]<a[2]<.......<a[m],然后对于k(1=<k<=m)都存在a[k]=a[i]+a[j](其中0<=i,j<=k-1)。

思路:dfs+剪枝

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int a[12000],b[12000];
int minn;
int n;
void dfs(int step)
{
    if(step>=minn)
        return;
    if(b[step-1]==n)
    {
        if(step<minn)
        {
            minn=step;
            for(int i=1;i<step;i++)
                a[i]=b[i];
        }
        return;
    }
    int s[1010];
    int k=0;
    for(int i=step-1;i>=1;i--)
    {
        for(int j=i;j>=1;j--)
        {
            if(b[i]+b[j]<=b[step-1])
                break;
            if(b[i]+b[j]<=n)
                s[k++]=b[i]+b[j];
        }
    }
    sort(s,s+k);
    for(int i=k-1;i>=0;i--)
    {
        b[step]=s[i];
        dfs(step+1);
    }
}
int main()
{
    while(~scanf("%d",&n)&&n)
    {
        minn=0x3f3f3f3f;
//        memset(a,0,sizeof(a));
//        memset(b,0,sizeof(b));
        b[1]=1;
        dfs(2);
        printf("%d",a[1]);
        for(int i=2; i<minn; i++)
            printf(" %d",a[i]);
        printf("\n");
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值