Tree Recovery (知前中求后)

Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes. 
This is an example of one of her creations: 

                                               D

                                              / \

                                             /   \

                                            B     E

                                           / \     \

                                          /   \     \

                                         A     C     G

                                                    /

                                                   /

                                                  F


To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree). For the tree drawn above the preorder traversal is DBACEGF and the inorder traversal is ABCDEFG. 
She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it). 

Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree. 
However, doing the reconstruction by hand, soon turned out to be tedious. 
So now she asks you to write a program that does the job for her! 

Input

The input will contain one or more test cases. 
Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.) 
Input is terminated by end of file. 
 

Output

For each test case, recover Valentine's binary tree and print one line containing the tree's postorder traversal (left subtree, right subtree, root).

Sample Input

DBACEGF ABCDEFG
BCAD CBAD

Sample Output

ACBFGED
CDAB

题目大意:已知一棵树的前序和中序遍历的结果,输出后序遍历的结果。

思路:1.前序:根-->左-->右

2.中序:左-->根-->右

3.后序:左-->右-->根

规律:

1.先序遍历第一个节点一定是根节点。

2.中序遍历根节点左侧就是树的左子树,右侧就是树的右子树。

3.后序遍历最后一个节点一定是根节点,而假设中序序列里根节点位置是m,那么 4.后序序列里0至m-1个节点是树的左子树节点,m至倒数第二个点是树的右子树节 点。

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct node
{
    char data;
    node *lson;
    node *rson;
    node()
    {
        lson=NULL;
        rson=NULL;
    }
};
node *inser(char *s1,char *s2,int l)
{
    if(l<=0)
        return NULL;
    node *root=new node();
    root->data=*s1;
    char *p;
    for(p=s2; p!=NULL; p++)//在中序遍历结果中找到 当前根,此时在中序序列中此根左边是左子树,右边是右子树

    {
        if(*p==*s1)
            break;
    }
    int kk=p-s2;//左子树的长度
    root->lson=inser(s1+1,s2,kk);//访问左子树
    root->rson=inser(s1+kk+1,s2+kk+1,l-kk-1);//访问右子树
    return root;

}
void out(node *root)
{
    if(root==NULL)
        return ;
    out(root->lson);
    out(root->rson);
    printf("%c",root->data);
}
int main()
{
    char a[10010],b[10010];
    while(~scanf("%s%s",a,b))
    {
        int l=strlen(a);
        node *root=new node();
        root=inser(a,b,l);
        out(root);
        printf("\n");
    }
    return 0;
}

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值