HDU - 1622 Trees on the level (二叉树的水平遍历)

Trees are fundamental in many branches of computer science. Current state-of-the art parallel computers such as Thinking Machines' CM-5 are based on fat trees. Quad- and octal-trees are fundamental to many algorithms in computer graphics. 

This problem involves building and traversing binary trees. 
Given a sequence of binary trees, you are to write a program that prints a level-order traversal of each tree. In this problem each node of a binary tree contains a positive integer and all binary trees have have fewer than 256 nodes. 

In a level-order traversal of a tree, the data in all nodes at a given level are printed in left-to-right order and all nodes at level k are printed before all nodes at level k+1. 

For example, a level order traversal of the tree 

 
is: 5, 4, 8, 11, 13, 4, 7, 2, 1. 

In this problem a binary tree is specified by a sequence of pairs (n,s) where n is the value at the node whose path from the root is given by the string s. A path is given be a sequence of L's and R's where L indicates a left branch and R indicates a right branch. In the tree diagrammed above, the node containing 13 is specified by (13,RL), and the node containing 2 is specified by (2,LLR). The root node is specified by (5,) where the empty string indicates the path from the root to itself. A binary tree is considered to be completely specified if every node on all root-to-node paths in the tree is given a value exactly once. 
 

Input

The input is a sequence of binary trees specified as described above. Each tree in a sequence consists of several pairs (n,s) as described above separated by whitespace. The last entry in each tree is (). No whitespace appears between left and right parentheses. 

All nodes contain a positive integer. Every tree in the input will consist of at least one node and no more than 256 nodes. Input is terminated by end-of-file. 
 

Output

For each completely specified binary tree in the input file, the level order traversal of that tree should be printed. If a tree is not completely specified, i.e., some node in the tree is NOT given a value or a node is given a value more than once, then the string ``not complete'' should be printed

Sample Input

(11,LL) (7,LLL) (8,R)
(5,) (4,L) (13,RL) (2,LLR) (1,RRR) (4,RR) ()
(3,L) (4,R) ()

Sample Output

5 4 8 11 13 4 7 2 1
not complete

题目大意:输入数据(x,s),x为节点的编号,s为从根节点到x的路径,L为左,R为右。(x, )为根节点,以()输入结束。

注:其中一组数据只能输入一次(所以输入多次也为不能构成),如果不能构成树输出 not complete。

思路:每个节点最多有两个儿子,且所在的层数等于路径加1,因此可以按所在层数的值,和路径s的大小从小到大排序 ,然后判断。

#include<stdio.h>
#include<string.h>
#include<map>
#include<string>
#include<iostream>
#include<algorithm>
using namespace std;
struct node
{
    int x,y;//x为节点的值,y为所在的层数
    string s;//路径
} q[10010];

bool cmp(node a,node b)
{
    if(a.y==b.y)
        return a.s<b.s;//字符L<R
    else
        return a.y<b.y;
}

int main()
{
    int n=0,flag=0;
    string str;
    map<string,int>mp;
    int ans[500];//
    while(cin>>str)
    {
        if(str=="()")//以()结束
        {
            sort(q,q+n,cmp);
            if(flag||q[0].y!=0)//q[0]为最上的根节点
            {
                printf("not complete\n");
            }
            else
            {
                for(int i=0; i<n; i++)
                {
                    if(q[i].y>0)
                    {
                        string s1;
                        int len=q[i].s.size();
                        for(int j=0; j<len-1; j++) //*******
                        {
                            s1+=q[i].s[j];
                        }
                        if(mp[s1]!=1)//一组数据出现的不仅一次
                        {
                            flag=1;
                            break;
                        }
                    }
                    ans[i]=q[i].x;
                }
                if(flag)
                    printf("not complete\n");
                else
                {
                    for(int i=0; i<n; i++)
                    {
                        if(i==0)
                            printf("%d",ans[i]);
                        else
                            printf(" %d",ans[i]);
                    }
                    printf("\n");
                }
            }
            n=flag=0;
            mp.clear();
            continue;
        }


        int l=str.size();
        int p=0,k;
        for(int i=1; i<l; i++)//逗号前的数据的处理
        {
            if(str[i]==',')
            {
                k=i;
                break;
            }
            p=p*10+(str[i]-48);
        }
        q[n].x=p;//
        p=0;
        int num=0;
        q[n].s.clear();
        for(int i=k+1; i<l; i++)
        {
            if(str[i]==')')
                break;
            num++;
            q[n].s+=str[i];//路径
        }
        mp[q[n].s]++;
        if(mp[q[n].s]>1)//只能出现一次
            flag=1;
        q[n].y=num;//层数
        n++;
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值