PAT 甲级——Build A Binary Search Tree

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.

figBST.jpg

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100) which is the total number of nodes in the tree. The next N lines each contains the left and the right children of a node in the format left_index right_index, provided that the nodes are numbered from 0 to N−1, and 0 is always the root. If one child is missing, then −1 will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.

Output Specification:

For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

9
1 6
2 3
-1 -1
-1 4
5 -1
-1 -1
7 -1
-1 8
-1 -1
73 45 11 58 82 25 67 38 42

Sample Output:

58 25 82 11 38 67 45 73 42

思路:

题目给出了二叉搜索树节点之间的关系以及该二叉搜索树结点的数据值的乱序排列。根据二叉搜索树的性质,我们知道它的中序序列是一个递增的序列,利用这个特点,我们只需要在中序遍历这颗树的时候,将按升序排列的数组里面的元素一个一个对应放到被访问结点的data值里面即可。

代码:

#include <iostream>
#include<algorithm>
#include<queue>
using namespace std;
const int maxn = 110;
int n,index=0,a[maxn] = { 0 },num=0;
struct  node
{
	int data;
	int lchild;
	int rchild;
}Node[maxn];

void inOrder(int root)
{
	if (root == -1) return;
	inOrder(Node[root].lchild);
	Node[root].data = a[index++];
	//printf_s("%d ", Node[root].data);
	inOrder(Node[root].rchild);

}

void layerOrder(int root)
{
	queue<int>Q;
	Q.push(root);
	while (!Q.empty())
	{
		int now = Q.front();
		printf("%d", Node[now].data);
		if (num < n - 1) printf(" ");
		else printf("\n");
		num++;
		Q.pop();
		if (Node[now].lchild != -1) Q.push(Node[now].lchild);
		if (Node[now].rchild != -1) Q.push(Node[now].rchild);
		

	}
}

int main()
{
	int left_child, right_child,data;
	scanf("%d", &n);
	for (int i = 0; i < n; i++)
	{
		scanf("%d%d", &left_child, &right_child);
		Node[i].lchild = left_child;
		Node[i].rchild = right_child;
	
	}
	for (int i = 0; i < n; i++)
	{
		scanf("%d", &a[i]);
	}
	sort(a, a + n);
	inOrder(0);
	layerOrder(0);
	return 0;


}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值