PAT甲级——Are They Equal

If a machine can save only 3 significant digits, the float numbers 12300 and 12358.9 are considered equal since they are both saved as 0.123×10​5​​ with simple chopping. Now given the number of significant digits on a machine and two float numbers, you are supposed to tell if they are treated equal in that machine.

Input Specification:

Each input file contains one test case which gives three numbers N, A and B, where N (<100) is the number of significant digits, and A and B are the two float numbers to be compared. Each float number is non-negative, no greater than 10​100​​, and that its total digit number is less than 100.

Output Specification:

For each test case, print in a line YES if the two numbers are treated equal, and then the number in the standard form 0.d[1]...d[N]*10^k (d[1]>0 unless the number is 0); or NO if they are not treated equal, and then the two numbers in their standard form. All the terms must be separated by a space, with no extra space at the end of a line.

Note: Simple chopping is assumed without rounding.

Sample Input 1:

3 12300 12358.9

Sample Output 1:

YES 0.123*10^5

Sample Input 2:

3 120 128

Sample Output 2:

NO 0.120*10^3 0.128*10^3

思路:输入的数是一个非负数,可以分为大于1和小于1两种情况,注意这里输入的数字前面可能有多余的0,比如0001.23。所以我们在处理数据的时候要注意把前面的0删除掉。

第一步,当输入的字符串长度大于1且第一个字符为‘0’的时候不断地删除前面的0。

第二步,当删除完多余的0之后,字符串的第一个字符为小数点,那么这是一个小于1的数,我们这时继续删除这个小数点,并且像刚才一样继续删除小数点后面的0,每删除一个0就代表该数的幂次减一(e--)。当删除多余的0之后,字符串的第一个字符不是小数点,那么这是一个大于一的数。我们设置一个变量k表示字符的位置,遍历剩下的字符串,看a[k]是否等于小数点,每往后查找一位,该数的幂次就加一。如果找到了小数点就把小数点删除。

第三步,定义字符串res,此时res为空字符串,不断给res加上处理后的字符串的第一位,直到满足精度n,要注意的是,如果处理后的字符串长度小于精度,那么应该在res后面加上‘0’。

第四步,在主函数里输入数据并且输出结果。


代码:

#include <iostream>
#include<string>
using namespace std;

int n;//有效位数
string deal(string s, int &e)
{
	int k = 0;//s的下标
	while (s.length()>0&&s[0]=='0')
	{
		s.erase(s.begin());//去掉前导0;
	}
	if (s[0] == '.') {//去除前导0后是小数点,说明是小于1的数
		s.erase(s.begin());
		while (s.length() > 0&&s[0]=='0')
		{
			s.erase(s.begin());
			e--;
		}

	}
	else {//去掉前导零后不是小数点,则找到小数点删除
		while (k < s.length() && s[k] != '.')
		{
			k++;
			e++;//只要不碰到小数点就让指数e++
		}
		if (k < s.length()) {
			s.erase(s.begin() + k);
		}
	}
	if (s.length() == 0)
	{
		e = 0;//去除前导零后s的长度变为0,说明这个数是0;
	}
	int num = 0;
	k = 0;
	string res;
	while (num<n)
	{
		if (k < s.length()) res += s[k++];
		else res += '0';
		num++;
	}
	return res;
}

int main()
{
	string s1, s2, s3, s4;
	cin >> n >> s1 >> s2;
	int e1 = 0, e2 = 0;
	s3 = deal(s1, e1);
	s4 = deal(s2, e2);
	if (s3 == s4 && e1 == e2)
	{
		cout << "YES 0." << s3 << "*10^" << e1 << endl;
	}
	else {
		cout << "NO 0." << s3 << "*10^" << e1 << " 0." << s4 << "*10^" << e2 << endl;
	}
	return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值