【编程题解】88888888...

Description

Eight is a lucky number in our daily life. If every digit of a number consists of eight,it is considered a lucky number.

The teacher now gave Lili a positive integer L, hoping that she could find out how many positive integers made up of 8 together are multiples of L, and asked for the minimum value. Lili felt very difficult, could you do it for her?

 

Input

The input contains multiple sets of test cases.

Each set of test cases occupies one row and contains an integer L.

When the input case L=0, the input is terminated and the use case does not need to be processed.

Data range:1≤L≤2∗10^9

 

Output

Each set of test cases has one line of output.

The result is "Case 1:" + an integer N, which represents the number of bits of the least lucky number that satisfies the condition.

If the lucky number that satisfies the condition does not exist, then N=0.

Sample Input 1 

8
11
16
0

Sample Output 1

Case 1:1
Case 2:2
Case 3:0

 

Personal Answer  (using language:JAVA)  Not necessarily right

import java.math.BigInteger;
import java.util.List;
import java.util.LinkedList;
import java.util.Scanner;

public class Main {
    public static void main(String[] args) {
        Scanner scanner = new Scanner(System.in);
        int times = 0;
        List<Integer> results = new LinkedList<>();
        int input = scanner.nextInt();
        while (input!=0){
            times++;
            results.add(cal(input));
            input = scanner.nextInt();
        }
        for (int i=0;i<results.size();i++){
            System.out.println("Case "+(i+1)+":"+results.get(i));
        }
    }

    public static int cal(int input){
        int weishu=(input+"").length();
        int tip=0;
        do{
            tip++;
            String s="";
            for(int i=0;i<tip;i++){
                s+="8";
            }
            BigInteger test_num=new BigInteger(s);
            BigInteger res =test_num.mod(new BigInteger(""+input));
            if(res.equals(new BigInteger("0"))){
                return tip;
            }
        }while(tip!=9999);
        return 0;
    }
}

Welcome to communicate!

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值