Poj.3267.Silver Cow Party(最短路)

Poj.3268.Silver Cow Party

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ XN). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input
Line 1: Three space-separated integers, respectively: N, M, and X
Lines 2.. M+1: Line i+1 describes road i with three space-separated integers: Ai, Bi, and Ti. The described road runs from farm Ai to farm Bi, requiring Ti time units to traverse.
Output
Line 1: One integer: the maximum of time any one cow must walk.
Sample Input
4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3
Sample Output
10
Hint
Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.


考点:最短路径,Dijkstra算法


#include<queue>
#include<vector>
#include<stdio.h>
#include<string.h>
#include<iostream>
using namespace std;
struct Edge
{
    int to;
    int dis;
    Edge(int to, int dis)
    {
        this -> to = to;
        this -> dis = dis;
    }
};
typedef pair<int,int>P;

int a,b,c;
int N,M,X;
int d1[1005],d2[1005];     //最短路径
vector<Edge> G1[1005];     //vector向量容器:在尾端插入和删除元素,时间复杂度O(1);其他位置O(n)
vector<Edge> G2[1005];     //vector向量容器:可动态调整所占的内存空间
void dijkstra(int s,int d[],vector<Edge> G[])
{
    priority_queue<P,vector<P>,greater<P> >q;
    d[s]=0;
    q.push(P(0,s));
    while(q.size())
    {
        P p=q.top();
        q.pop();
        int v=p.second;
        for(int i=0; i<G[v].size(); i++)
        {
            Edge& e=G[v][i];
            if(d[e.to]>d[v]+e.dis)
            {
                d[e.to]=d[v]+e.dis;
                q.push(P(d[e.to],e.to));
            }
        }
    }
}
int main()
{
    memset(d1,0x5f,sizeof(d1));
    memset(d2,0x5f,sizeof(d2));
    scanf("%d%d%d",&N,&M,&X);                   //结点2·边数·终点
    for(int i=1; i<=M; i++)
    {
        scanf("%d%d%d",&a,&b,&c);
        G1[a].push_back(Edge(b,c));             //尾端插入新元素:牛a到牛b需要花费c时间
        G2[b].push_back(Edge(a,c));
    }
    dijkstra(X,d1,G1);                          //双向求出两次X->m的最短路径
    dijkstra(X,d2,G2);
    int small_max=-1;
    for(int i=1; i<=N; i++)
    {
        if(i==X) continue;
        small_max=max(small_max,d1[i]+d2[i]);   //两次最短路径相加即得到m->X->m的最短路径
    }
    cout<<small_max<<endl;
}


深度学习是机器学习的一个子领域,它基于人工神经网络的研究,特别是利用多层次的神经网络来进行学习和模式识别。深度学习模型能够学习数据的高层次特征,这些特征对于图像和语音识别、自然语言处理、医学图像分析等应用至关重要。以下是深度学习的一些关键概念和组成部分: 1. **神经网络(Neural Networks)**:深度学习的基础是人工神经网络,它是由多个层组成的网络结构,包括输入层、隐藏层和输出层。每个层由多个神经元组成,神经元之间通过权重连接。 2. **前馈神经网络(Feedforward Neural Networks)**:这是最常见的神经网络类型,信息从输入层流向隐藏层,最终到达输出层。 3. **卷积神经网络(Convolutional Neural Networks, CNNs)**:这种网络特别适合处理具有网格结构的数据,如图像。它们使用卷积层来提取图像的特征。 4. **循环神经网络(Recurrent Neural Networks, RNNs)**:这种网络能够处理序列数据,如时间序列或自然语言,因为它们具有记忆功能,能够捕捉数据中的时间依赖性。 5. **长短期记忆网络(Long Short-Term Memory, LSTM)**:LSTM 是一种特殊的 RNN,它能够学习长期依赖关系,非常适合复杂的序列预测任务。 6. **生成对抗网络(Generative Adversarial Networks, GANs)**:由两个网络组成,一个生成器和一个判别器,它们相互竞争,生成器生成数据,判别器评估数据的真实性。 7. **深度学习框架**:如 TensorFlow、Keras、PyTorch 等,这些框架提供了构建、训练和部署深度学习模型的工具和库。 8. **激活函数(Activation Functions)**:如 ReLU、Sigmoid、Tanh 等,它们在神经网络中用于添加非线性,使得网络能够学习复杂的函数。 9. **损失函数(Loss Functions)**:用于评估模型的预测与真实值之间的差异,常见的损失函数包括均方误差(MSE)、交叉熵(Cross-Entropy)等。 10. **优化算法(Optimization Algorithms)**:如梯度下降(Gradient Descent)、随机梯度下降(SGD)、Adam 等,用于更新网络权重,以最小化损失函数。 11. **正则化(Regularization)**:技术如 Dropout、L1/L2 正则化等,用于防止模型过拟合。 12. **迁移学习(Transfer Learning)**:利用在一个任务上训练好的模型来提高另一个相关任务的性能。 深度学习在许多领域都取得了显著的成就,但它也面临着一些挑战,如对大量数据的依赖、模型的解释性差、计算资源消耗大等。研究人员正在不断探索新的方法来解决这些问题。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值