Hdu.1576.A/B(拓展欧几里得算法)

J - A/B

Time Limit: 1000 MS Memory Limit: 32768 KB

64-bit integer IO format: %I64d , %I64u Java class name: Main

[Submit] [Status]

Description

要求(A/B)%9973,但由于A很大,我们只给出n(n=A%9973)(我们给定的A必能被B整除,且gcd(B,9973) = 1)。

Input

数据的第一行是一个T,表示有T组数据。
每组数据有两个数n(0 <= n < 9973)和B(1 <= B <= 10^9)。

Output

对应每组数据输出(A/B)%9973。

Sample Input

2
1000 53
87 123456789

Sample Output

7922
6060

考点:拓展欧几里得算法

#include<stdio.h>
#include<iostream>
using namespace std;
int t,p;
void extend_gcd(int a,int b){
    if(b==0){
        t=1;
        p=0;
    }else{
        extend_gcd(b,a%b);
        int temp=t;
        t=p;
        p=temp-a/b*p;
    }
}
int main(){
    int a;
    int n,b;
    scanf("%d",&a);
    while(a--&&scanf("%d%d",&n,&b)){
        extend_gcd(b,9973);
        t*=n;
           t=(9973+t%9973)%9973;//最小正整数解
        printf("%d\n",t);
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值