HDU-5538 House Building(思维)

问题 L: House Building

时间限制: 1 Sec  内存限制: 128 MB
提交: 66  解决: 49
[提交] [状态] [讨论版] [命题人:admin]

题目描述

Have you ever played the video game Minecraft? This game has been one of the world’s most popular game in recent years. The world of Minecraft is made up of lots of 1×1×1 blocks in a 3D map. Blocks are the basic units of structure in Minecraft, there are many types of blocks. A block can either be a clay, dirt, water, wood, air, ...or even a building material such as brick or concrete in this game.

figure 1: A typical world in Minecraft.

Nyanko-san is one of the diehard fans of the game, what he loves most is to build monumental houses in the world of the game. One day, he found a flat ground in some place. Yes, a super flat ground without any roughness, it’s really a lovely place to build houses on it. Nyanko-san decided to build on a n ×m big flat ground, so he drew a blueprint of his house, and found some building materials to build.
While everything seems goes smoothly, something wrong happened. Nyanko-san found out he had forgotten to prepare glass elements, which is a important element to decorate his house. Now Nyanko-san gives you his blueprint of house and asking for your help. Your job is quite easy, collecting a sufficient number of the glass unit for building his house. But first, you have to calculate how many units of glass should be collected.
There are n rows and m columns on the ground, an intersection of a row and a column is a 1×1 square,and a square is a valid place for players to put blocks on. And to simplify this problem, Nynako-san’s blueprint can be represented as an integer array ci,j (1≤i≤n, 1≤j≤m). Which ci,j indicates the height of his house on the square of i-th row and j-th column. The number of glass unit that you need to collect is equal to the surface area of Nyanko-san’s house(exclude the face adjacent to the ground).

 

输入

The first line contains an integer T indicating the total number of test cases. First line of each test case is a line with two integers n, m. The n lines that follow describe the array of Nyanko-san’s blueprint, the i-th of these lines has m integers ci,1 , ci,2 , ..., ci,m , separated by a single space.
1≤T≤50
1≤n, m≤50
0≤ci,j≤1000

 

输出

For each test case, please output the number of glass units you need to collect to meet Nyanko-san’s requirement in one line.

 

样例输入

2
3 3
1 0 0
3 1 2
1 1 0
3 3
1 0 1
0 0 0
1 0 1

 

样例输出

30
20

 

提示

 

[提交][状态]

#include<bits/stdc++.h>
using namespace std;
#define maxn 55
#define M(a) memset(a,0,sizeof(a))
#define rep(i,a) for(int i=1;i<=a;i++)
#define rp(i,a) for(int i=0;i<a;i++)

int dir[][2]={{0, 1},{0, -1},{1, 0},{-1, 0}};
int G[maxn][maxn];

int main () {
    int t,n,m;
    cin>>t;
    while(t--&&cin>>n>>m){
        M(G);
        int ans = 0;
        rep(i,n){
            rep(j,m) cin>>G[i][j];
        }

        rep(i,n){
            rep(j,m){
                if(G[i][j]) ans++;
                rp(k,4){
                    int x=i+dir[k][0],y=j+dir[k][1];
                    ans+=max(G[i][j]-G[x][y],0);
                }
            }
        }
        cout<<ans<<endl;
    }
    return 0;
}


 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值