Python实现Pat 1003. Emergency (25)

33 篇文章 0 订阅

题目

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (<= 500) - the number of cities (and the cities are numbered from 0 to N-1), M - the number of roads, C1 and C2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.

Output

For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather.
All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input
5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1
Sample Output
2 4

解答

#求图上两点间的最短路径,并求最短路径上的最大权值和,如果仅一条最短路径,即为该条路径的权值和
INT_MAX=100000
mind =INT_MAX
maxw=0 #最短路径权值和的最大值
cnt=1 #最短路径条数
N,M,c1,c2=[int(x) for x in input().split(' ')]
wei=[int(x) for x in input().split(' ')]
visit=[-1]*N
#road 为列表的列表,不能用road=[tem[:]]*N,这样各行实际指向同一列表。要避免这种浅复制
#road[i][j]=INT_MAX,代表图上不存在i和j间的边
tem=[INT_MAX]*N
road=[]
for i in range(N):
    road.append(tem[:])
#读入各边的长度
for r in range(M):
    i,j,dist=[int(x) for x in input().split(' ')]
    road[i][j]=dist
    road[j][i] = dist

def dfs( p, end, dist, weit):
    global mind,cnt,maxw,N,wei,visit
    if(p==end):
        if(dist<mind):
            cnt = 1
            mind=dist
            maxw = weit
        elif(dist==mind):
            cnt+=1
            if(maxw<weit):
                maxw = weit
        return 0
    if (dist > mind): #如果该路径的长度已经超过已知的最短路径了的话,就没必要继续迭代了
        return 1
    for i in range(N):
        if(visit[i] == -1 and road[p][i] != INT_MAX):
            visit[i] = 1
            dfs(i, end, dist + road[p][i], weit + wei[i])
            visit[i] = -1
visit[c1] = 1
dfs(c1, c2, 0, wei[c1])
print (cnt, maxw)

这里写图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值