Largest Rectangle in a Histogram POJ - 2559 单调栈

Largest Rectangle in a Histogram
Time Limit: 1000MS
 Memory Limit: 65536K
Total Submissions: 21505 Accepted: 6932

Description

A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles:

Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.

Input

The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1<=n<=100000. Then follow n integers h1,...,hn, where 0<=hi<=1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.

Output

For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.

Sample Input

7 2 1 4 5 1 3 3
4 1000 1000 1000 1000
0

Sample Output

8
4000

Hint

Huge input, scanf is recommended.

Source


单调栈,打比赛的时候碰到的,结果果断不会,主要是以前没有接触过这类的题型,还是多刷题多思考吧!!!
题目的意思是给你一堆宽度相同的举行,让你从中切割一个最大的矩形。
用单调栈,如果一个进栈元素比栈顶元素的高度要低的话,就要进栈(单调栈顾名思义,栈中元素始终单调),遇到比它小的就要出栈,直到进栈元素比栈顶元素的值要大。
这里给出代码,理解一下,还是比较好理解的
#include<stack>
#include<iostream>
#include<stdio.h>
using namespace std;
struct aa
{
    long long time;
    long long wid;
} x;
int main()
{

    int n;
    while(scanf("%d",&n)!=EOF&&n)
    {
        stack<struct aa>ycq;
        long long maxx=-1;
        for(int i=0; i<n; i++)
        {
            long long temp;
            scanf("%lld",&temp);
            x.wid=temp;
            int c=0;
            while(!ycq.empty()&&ycq.top().wid>=x.wid)
            {
                if((c+ycq.top().time)*ycq.top().wid>maxx)
                    maxx=(c+ycq.top().time)*ycq.top().wid;
                c+=ycq.top().time;
                ycq.pop();
            }
            x.time=c+1;
            ycq.push(x);
        }
        int c=0;
        while(!ycq.empty())
        {
            if((c+ycq.top().time)*ycq.top().wid>maxx)
                maxx=(c+ycq.top().time)*ycq.top().wid;
            c+=ycq.top().time;
            ycq.pop();

        }
        printf("%lld\n",maxx);
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值