Layout POJ - 3169 差分约束

Like everyone else, cows like to stand close to their friends when queuing for feed. FJ has N (2 <= N <= 1,000) cows numbered 1..N standing along a straight line waiting for feed. The cows are standing in the same order as they are numbered, and since they can be rather pushy, it is possible that two or more cows can line up at exactly the same location (that is, if we think of each cow as being located at some coordinate on a number line, then it is possible for two or more cows to share the same coordinate).

Some cows like each other and want to be within a certain distance of each other in line. Some really dislike each other and want to be separated by at least a certain distance. A list of ML (1 <= ML <= 10,000) constraints describes which cows like each other and the maximum distance by which they may be separated; a subsequent list of MD constraints (1 <= MD <= 10,000) tells which cows dislike each other and the minimum distance by which they must be separated.

Your job is to compute, if possible, the maximum possible distance between cow 1 and cow N that satisfies the distance constraints.
Input
Line 1: Three space-separated integers: N, ML, and MD.

Lines 2..ML+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at most D (1 <= D <= 1,000,000) apart.

Lines ML+2..ML+MD+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at least D (1 <= D <= 1,000,000) apart.
Output
Line 1: A single integer. If no line-up is possible, output -1. If cows 1 and N can be arbitrarily far apart, output -2. Otherwise output the greatest possible distance between cows 1 and N.
Sample Input
4 2 1
1 3 10
2 4 20
2 3 3
Sample Output
27
Hint
Explanation of the sample:

There are 4 cows. Cows #1 and #3 must be no more than 10 units apart, cows #2 and #4 must be no more than 20 units apart, and cows #2 and #3 dislike each other and must be no fewer than 3 units apart.

The best layout, in terms of coordinates on a number line, is to put cow #1 at 0, cow #2 at 7, cow #3 at 10, and cow #4 at 27.

题目大概的意思就是说有从1-n编号的牛,有一些牛相互讨厌,有一些牛相互喜欢,所有牛与牛的距离有一定的范围,相互喜欢的牛有距离最大值,相互讨厌的牛有距离最小值.
现在让你求一号牛与n号牛距离的最大值.
读完题目之后发现时差分约束.
约束条件如上叙述.让求得最大值.那么一定是dist[n]-dist[1]<=t
简单移项之后dist[n]<=t+dist[1]
所有我们必须用最小路中的dist[n]>t+dist[1]就松弛的条件来逼近dist[n]-dist[1]<=t以求得最大值
下面是代码






#include<stdio.h>
#include<queue>
#include<string>
#include<algorithm>
using namespace std;
struct aa
{
    int u,v,w,next;
} edge[38000];
bool vis[1080];
int dist[1080];
int cnt,n;
int per[1080];
int time1[1080];
void init()
{
    for(int i=1; i<=n; i++)
    {
        dist[i]=0x3f3f3f3f;
        vis[i]=0;
        per[i]=-1;
        time1[i]=0;
    }
}
void add(int u,int v,int w)
{
    edge[cnt].u=u;
    edge[cnt].v=v;
    edge[cnt].w=w;
    edge[cnt].next=per[u];
    per[u]=cnt++;
}
void spfa()
{
    dist[1]=0;
    queue<int>ycq;
    ycq.push(1);
    time1[1]++;
    while(!ycq.empty())
    {
        int t=ycq.front();
        vis[t]=0;
        ycq.pop();
        for(int i=per[t]; i!=-1; i=edge[i].next)
        {
            int u=edge[i].u,v=edge[i].v,w=edge[i].w;

            if(dist[v]>dist[u]+w)
            {
                dist[v]=dist[u]+w;
             //   printf("%d %d %d %d\n",u,v,dist[u],dist[v]);
                if(!vis[v])
                {
                    vis[v]=1;
                    ycq.push(v);
                    time1[v]++;
                    if(time1[v]>n)
                    {
                        printf("-1\n");
                        return ;
                    }


                }
            }
        }
    }
    if(dist[n]==0x3f3f3f3f)
    {
        printf("-2\n");
        return ;
    }
    printf("%d\n",dist[n]);
    return ;



}
int main()
{
    int m1,m2;
    while(scanf("%d%d%d",&n,&m1,&m2)!=EOF)
    {
        init();
        while(m1--)
        {
            int u,v,w;
            scanf("%d%d%d",&u,&v,&w);
            if(u>v)
                swap(u,v);//小节点指向大节点
            add(u,v,w);
        }
        while(m2--)
        {
            int u,v,w;
            scanf("%d%d%d",&u,&v,&w);
            if(u>v)
                swap(u,v);
            add(v,u,-w);

        }
        spfa();
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值