POJ 1733 Parity game 带权并查集+离散化处理

Now and then you play the following game with your friend. Your friend writes down a sequence consisting of zeroes and ones. You choose a continuous subsequence (for example the subsequence from the third to the fifth digit inclusively) and ask him, whether this subsequence contains even or odd number of ones. Your friend answers your question and you can ask him about another subsequence and so on. Your task is to guess the entire sequence of numbers.

You suspect some of your friend's answers may not be correct and you want to convict him of falsehood. Thus you have decided to write a program to help you in this matter. The program will receive a series of your questions together with the answers you have received from your friend. The aim of this program is to find the first answer which is provably wrong, i.e. that there exists a sequence satisfying answers to all the previous questions, but no such sequence satisfies this answer. Input
The first line of input contains one number, which is the length of the sequence of zeroes and ones. This length is less or equal to 1000000000. In the second line, there is one positive integer which is the number of questions asked and answers to them. The number of questions and answers is less or equal to 5000. The remaining lines specify questions and answers. Each line contains one question and the answer to this question: two integers (the position of the first and last digit in the chosen subsequence) and one word which is either `even' or `odd' (the answer, i.e. the parity of the number of ones in the chosen subsequence, where `even' means an even number of ones and `odd' means an odd number).
Output
There is only one line in output containing one integer X. Number X says that there exists a sequence of zeroes and ones satisfying first X parity conditions, but there exists none satisfying X+1 conditions. If there exists a sequence of zeroes and ones satisfying all the given conditions, then number X should be the number of all the questions asked.
Sample Input
10
5
1 2 even
3 4 odd
5 6 even
1 6 even
7 10 odd
Sample Output
3
哈哈,又到了写题解的时刻了。大笑
这次的题目是给你几个区间的范围以及里面1的个数是奇数还是偶数,然后让你求前多少个描述是对的。
题目的知识点就是我题解题目上给出的了,至于为什么是这种知识点,我讲不出来,只能靠做题的感觉。
当你做的题目多了,你拿到一个题就大概知道是什么知识点。
下面说几个问题。
1.为什么要离散化?
注意给出的数据范围是1-1000000000,而给出的描述最多不过5000,这样的话,就会产生一个问题,当处理完整个描述的时候,这是数组产生的空白会非常多。
并且,你没法开这么大的数组。所以,说白了,你要压缩这些节点,恰恰这是并查集,就是给你一个区间吧[a,b]。这仅仅是说明了a与b有关系,这个关系是a,b
之间的1的个数的奇偶。仅仅是两个节点的关系。既然仅仅说明两个节点的关系,那么我们就可以用一个map把他们从头到尾编号。而且这些编号可以没有顺序。
2.两个节点的关系怎么查找?- -!说实话,你可以试试,就是去找规律,一开始初始化关系一般是0,你枚举三个节点试试,如果这三个成立,那么这个总结公式基本
就是成立的。
。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。
3.具体怎么做?
AC代码如下,个人感觉还是比较清楚的
#include<stdio.h>//0代表o数,1代表j数
#include<string.h>
#include<algorithm>
#include<map>
using namespace std;
int pre[233333];
int rale[233333];
char s[10];
int k=0;
int findboss(int x)
{
    if(x==pre[x])
        return x;
    else
    {
        int t=pre[x];
        pre[x]=findboss(pre[x]);
        rale[x]=rale[x]^rale[t];
        return pre[x];
    }
}
int main()
{
//freopen("out","w",stdout);
    int n,m;
    scanf("%d%d",&n,&m);
    int ans=0;
    map<int,int>ycq;
    for(int i=0; i<=11000; i++)
    {
        rale[i]=0;
        pre[i]=i;
    }
    while(m--)
    {
        int u,v,w;
        scanf("%d%d",&u,&v);
        u--;
        if(ycq.find(u)==ycq.end())
        ycq[u]=k++;
        if(ycq.find(v)==ycq.end())
        ycq[v]=k++;
        u=ycq[u];
        v=ycq[v];
        scanf("%s",s);
        if(s[0]=='o')
            w=1;
        else
            w=0;
      //  printf("***%d %d %d***\n",u,v,w);
        int aa=findboss(u),bb=findboss(v);
        if(aa==bb)
        {
            if((rale[v]^rale[u])==w)
                ans++;
            else
                break;

        }
        else
        {
            pre[bb]=aa;
            rale[bb]=(rale[u]^rale[v]^w);
            ans++;
        }

    }
    printf("%d\n",ans);
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值