Satisfactory Pairs HackerRank - pairs-again

Given a positive integer, , find and print the number of pairs of positive integers , where , that exist such that the equation (where and are positive integers) has at least one solution.

Input Format

A single positive integer denoting .

Constraints

Output Format

Print a single integer denoting the number of such pairs.

Sample Input 0

4

Sample Output 0

2
比赛的题,感觉这些题目质量都很差
1.测试数据少,有的题目可能不需要什么算法就能过
2.不给你写时间限制,基本靠感觉。
枚举a,枚举x,这样可以算出yb是什么,对于yb来说,在枚举yb的因数。这样算一下,比直接枚举快多了。
其实就等于提前打了个因数表,每次不用再算一遍。
快就快再这里。然而就算快也是跑了接近15秒钟。
#include<bits/stdc++.h>
using namespace std;
vector<int>ycq[300010];
int mach[300010];
typedef vector<int>::iterator it;
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        int sum=0;
        for(int i=1; i<=n; i++)
        {
            mach[i]=0;
            for(int j=1; j*j<=n; j++)
            {
                if(i%j==0)
                {
                    ycq[i].push_back(j);
                    if(j*j!=i)
                    {
                        ycq[i].push_back(i/j);
                    }
                }
            }
            sort(ycq[i].begin(),ycq[i].end(),greater<int>());
        }

        for(int a=1; a<n; a++)
        {
            for(int x=1; x*a<n; x++)
            {
                int yb=n-x*a;
                for(it itt=ycq[yb].begin(); itt!=ycq[yb].end(); itt++)
                {
                    if((*itt)<=a)
                        break;
                    if(mach[*itt]!=a)
                    {
                        sum++;
                        mach[*itt]=a;
                    }
                }

            }
        }
        printf("%d\n",sum);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值